1. 程式人生 > >Hdoj.2058 The sum problem【數列】 2015/11/24

Hdoj.2058 The sum problem【數列】 2015/11/24

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 19595    Accepted Submission(s): 5779

Problem Description Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
Input Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input 20 10 50 30 0 0
Sample Output [1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
Author 8600
Source 感覺智商越來越低了,什麼都想不出來,這些題也不算難,可是就是想不出來。。。。。。
#include<iostream>
#include<cstdio>
#include<cmath>

using namespace std;

int main(){
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        if( !n&&!m ) break;
        for( int i = (int)sqrt(2*m) ; i > 0 ; --i ){
            int a = m / i - ( i - 1 ) / 2;
            if( (2*a-1+i)*i == 2*m )
                printf("[%d,%d]\n",a,a+i-1);
        }
        printf("\n");
    }
    return 0;
}