1. 程式人生 > >poj 2485(最小生成樹 Prim)

poj 2485(最小生成樹 Prim)

Highways
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15109 Accepted: 7034

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU 題目型別:最小生成樹 題目描述:求最小生成樹中,權值最大的邊。 題目分析:Prim演算法的特點是集合A中的邊總是形成單棵樹,樹從任意頂點r開始形成,並逐漸生成,直至樹覆蓋了V種的所有的頂點 在每一步,一條連線了樹A與G(A) = (V,A)中某一孤立頂點的輕邊被加入到樹A中。 程式碼如下:
#include <iostream>
#include <stdio.h>
#define V 501
#define M 65537
using namespace std;

int n;
int map[V][V];
int key[V];
bool visit[V];

int minKey(){
    int min = M;
    int pos = -1;
    for(int i = 0; i < n; i++){
        if( key[i] < min && !visit[i]){
            min = key[i];
            pos = i;
        }
    }
    return pos;
}
void update(int pos){
    for(int i = 0; i < n; i++){
        if( !visit[i] && map[pos][i] < key[i]){
            key[i] = map[pos][i];
        }
    }
}

int prim(){
    int max = -1;

    for(int i = 0; i < n;i++){
        visit[i] = false;
    }
    visit[0] = true;
    for(int i = 0; i < n;i++){
        key[i] = map[0][i];
    }
    for(int i = 1; i <= n-1; i++){
        int pos = minKey();
        visit[pos] = true;
        if(key[pos] > max) {
            max = key[pos];
        }
        update(pos);
    }
    return max;

}



int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
            scanf("%d",&n);
            for(int i = 0; i < n; i++){
                for(int j = 0; j < n; j++){
                    scanf("%d",&map[i][j]);
                }
            }
            printf("%d\n",prim());
    }

    return 0;
}