1. 程式人生 > >字串的處理(模擬) ZOJ Problem Set

字串的處理(模擬) ZOJ Problem Set

HTML
Time Limit: 2 Seconds      Memory Limit: 65536 KB

If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br>

which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.

Input Specification

The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, "abc,123
" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.

Output Specification

You should display the the resulting text using this rules:
  • If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
  • If you read a <br> in the input, start a new line.
  • If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again).
The last line is ended by a newline character.

Sample Input

Hallo, dies ist eine 
ziemlich lange Zeile, die in Html
aber nicht umgebrochen wird.
<br>
Zwei <br> <br> produzieren zwei Newlines. 
Es gibt auch noch das tag <hr> was einen Trenner darstellt.
Zwei <hr> <hr> produzieren zwei Horizontal Rulers.
Achtung       mehrere Leerzeichen irritieren

Html genauso wenig wie


mehrere Leerzeilen.

Sample Output

Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen
wird.
Zwei

produzieren zwei Newlines. Es gibt auch noch das tag
--------------------------------------------------------------------------------
was einen Trenner darstellt. Zwei
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html
genauso wenig wie mehrere Leerzeilen.
題目意思很明確:就是模擬html上的<br><hr>操作嘛,中間要處理一個總字元不超過80的情況

程式碼一看就懂

#include<stdio.h>
#include<string.h>
int main()
{
	char str[90];
	int leng = 0;
	while(scanf("%s",str)!=EOF)
	{
		if(strcmp(str,"<br>")==0)
		{
			printf("\n");
			leng=0;
		}
		else if(strcmp(str,"<hr>")==0)
		{
			if(leng!=0)
			{
				printf("\n");
			}
			for(int i=0;i<80;i++)
			{
				printf("-");
			}
			printf("\n");
			leng=0;
		}
		else 
		{
			if(leng==0)
			{
				printf("%s",str);
				leng+=strlen(str);
			}
			else if(leng+1+strlen(str)<=80)
			{
				printf(" %s",str);
				leng+=strlen(str)+1;
			}
			else 
			{ 
				printf("\n");
				leng =strlen(str);
				printf("%s",str);
			}
		}

	}
}

這樣輸入中的空格就沒有了,所以我們要來處理空格的情況,為了防止每行的末尾出現空格我決定在單詞前來處理空格,,別忘了空格也是一個字元。

好了!

感謝自己堅持!