1. 程式人生 > >POJ--3279(開關問題2個不同時間寫的代碼)

POJ--3279(開關問題2個不同時間寫的代碼)

and 不同的 there algo 時間復雜度 sid pac possible 復雜

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19730 Accepted: 7118

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N

grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

思路:
因為求解的是最小按鍵次數,如果將所有都遍歷的話,時間復雜度為 2^(N*M)太大了,因為開關按下,上下左右和它自己都會變化,所以,讓第一行出現2^m次不同的情況,用二進制表示

也就是for(int i=0;i< 1<<m; i++)種不同情況, 然後將i轉化為二進制。這樣就可以代表具體開關的地方,第二行以及以後就可以根據第一行進行遍歷了。因為第一行已經確定了所以,第二行就專門去尋找第一行還沒有關的燈,比如:map[i][j] = 1,就按下a[i+1][j]處的開關保證i+1行開關按後,第i行的燈全部關閉為0 最後判斷這種情況是否正確,然後判斷是否最小,記錄下來輸出。

#include <stdio.h>
#include <cstring>
#include <algorithm>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <iostream>
using namespace std;
int map[20][20],mm[20][20];
int a[20][20],A[20][20];
int d[5][2] = {0,0,1,0,-1,0,0,1,0,-1};

int get_s(int x,  int y){
    if(map[x][y]==1) return 0;
    else return 1;
}
int main(){
    int n,m;
    cin>>n>>m;
    memset(map,0,sizeof(map));
    for(int i=1;i<=n;i++){
        for(int j=1;j<=m;j++){
            cin>>map[i][j];
        }
    }
    memcpy(mm,map,sizeof(map));
    
    int minn = 1e9;
    for( int i = 0; i < 1<<m; i++ ) {
        int count=0,flag = 0;
        memset(a,0,sizeof(a));
        memcpy(map,mm,sizeof(mm));
        //第一行解決 將 i 轉化為 二進制
        for(int j=1;j<=m;j++){
            a[1][j] = (i>>(j-1))&1;
            if( a[1][j] == 1){
                count++;
                map[1][j]   = get_s(1,j);
                map[1][j-1] = get_s(1,j-1);
                map[1][j+1] = get_s(1,j+1);
                map[2][j]   = get_s(2,j);
            }
        } 

        for( int j = 1; j < n; j++ ) {
            for( int k = 1; k <= m; k++ ) {
                if( map[j][k] == 1 ) {
                    a[j+1][k] = 1;
                    int dx = j+1, dy = k, tx, ty;
                    count++; 
                    for( int z = 0; z < 5; z++ ) {
                        tx = dx + d[z][0];
                        ty = dy + d[z][1];
//                        cout<<tx<<" "<<ty<<endl; 
                        map[tx][ty] = get_s(tx,ty);
                    }
//                    cout<<map[j][k]<<"  "<<" j = "<<j<<" k = "<<k<<endl;
                }
                
            }
        }
        for( int j = 1; j <= m; j++ ) {
            if(map[n][j]==1) flag = 1;
        }
        
        if( flag ) continue;
        else {
            if( count < minn ) {
                minn = count;
                memcpy(A,a,sizeof(a));
            }
        }
    
    }
    if(minn == 1e9) printf("IMPOSSIBLE\n");
    else{
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                printf("%d%c",A[i][j],j==m?\n: );
    }
    return 0;
} 

POJ--3279(開關問題2個不同時間寫的代碼)