1. 程式人生 > >Best Reward kmp

Best Reward kmp

首字符 hid inf show ngs closed script tmp cond

  

Problem Description After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit.

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.)

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li.

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones‘ value. while a necklace that is not palindrom has value zero.

Now the problem is: how to cut the given necklace so that the sum of the two necklaces‘s value is greatest. Output this value.

Input The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows.

For each test case, the first line is 26 integers: v1, v2, ..., v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind.

The second line of each test case is a string made up of charactor ‘a‘ to ‘z‘. representing the necklace. Different charactor representing different kinds of gemstones, and the value of ‘a‘ is v1, the value of ‘b‘ is v2, ..., and so on. The length of the string is no more than 500000.

Output Output a single Integer: the maximum value General Li can get from the necklace.

Sample Input 2 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 aba 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 acacac

Sample Output 1 6

本來以為kmp可以判斷回文 但是遇到 abba next 就不能判斷了 應該先驗證思路再開始敲代碼的 還調試了半天 。。。 參考了大佬的做法: 要用拓展ekmp來求回文串

分析:

首先原始串為S,將S逆轉得到串T.(S=abcaaa,那麽T=aaacba).

S串的後綴回文:即S串中區間[i,n-1]的串是不是回文?

  技術分享圖片

將S作為主串,T串用擴展KMP算法去匹配S,extend1[n]數組保存匹配結果.如果extend1[i]+i==n時(n為S的長),那麽以S[i]為首字符一直到底n-1位置的串是回文串,否則不是.(自己舉個例子驗證一下)

S串的前綴回文:即S串中區間[0,i-1]的串是不是回文?

技術分享圖片

將T作為主串,S串用擴展KMP算法去匹配T,extend2[n]數組保存匹配結果.如果extend2[len-i]+len-i==n時(n為S的長),那麽以S[i-1]為尾字符一直到0位置的串是回文串,否則不是.(自己舉個例子驗證一下)

仔細思考下上面的模型.

技術分享圖片
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>
using namespace std;

void EKMP(char s[],char t[],int nex[],int extend[])//s為主串,t為模板串
{
    int i,j,p,L;
    int lens=strlen(s);
    int lent=strlen(t);
    nex[0]=lent;
    j=0;
    while(j+1<lent && t[j]==t[j+1])j++;
    nex[1]=j;

    int a=1;
    for(i=2;i<lent;i++)
    {
        p=nex[a]+a-1;
        L=nex[i-a];
        if(i+L<p+1)nex[i]=L;
        else
        {
            j=max(0,p-i+1);
            while(i+j<lent && t[i+j]==t[j])j++;
            nex[i]=j;
            a=i;
        }
    }

    j=0;
    while(j<lens && j<lent && s[j]==t[j])j++;
    extend[0]=j;
    a=0;
    for(i=1;i<lens;i++)
    {
        p=extend[a]+a-1;
        L=nex[i-a];
        if(L+i<p+1)extend[i]=L;
        else
        {
            j=max(0,p-i+1);
            while(i+j<lens && j<lent && s[i+j]==t[j])j++;
            extend[i]=j;
            a=i;
        }
    }
}

const int MAXN=500010;
char str1[MAXN],str2[MAXN];
int sum[MAXN];
int v[27];
int nex[MAXN];
int extend1[MAXN],extend2[MAXN];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        for(int i=0;i<26;i++)
            scanf("%d",&v[i]);
        scanf("%s",str1);
        int len=strlen(str1);
        sum[0]=0;
        for(int i=0;i<len;i++)
        {
            sum[i+1]=sum[i]+v[str1[i]-a];
            str2[i]=str1[len-1-i];
        }
        str2[len]=0;
        EKMP(str2,str1,nex,extend1);
        EKMP(str1,str2,nex,extend2);
        int ans=-10000;
        //需要保證分成兩部分,所以i從1到len-1
        for(int i=1;i<len;i++)
        {
            int tmp=0;
            if(i+extend1[i]==len)
            {
                tmp+=sum[len-i];
            }
            int pos=len-i;
            if(pos+extend2[pos]==len)
            {
                tmp+=sum[len]-sum[pos];
            }
            if(tmp>ans)ans=tmp;
        }
        printf("%d\n",ans);
    }
    return 0;
}
View Code

Best Reward kmp