1. 程式人生 > 實用技巧 >USACO Bad Hair Day

USACO Bad Hair Day

USACO Bad Hair Day

洛谷傳送門

POJ傳送門

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi

≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        ==       ==   -   =         Cows facing right -->=   =   == - = = == = = = = =1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c

1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

題解:

單調棧模板。

程式碼:

#include<cstdio>
#include<stack>
#define int long long
using namespace std;
const int maxn=80002;
int n,ans;
stack<int> st;
int h[maxn];
signed main()
{
	scanf("%lld",&n);
	for(int i=1;i<=n;i++)
		scanf("%lld",&h[i]);
	h[n+1]=1e9;
	for(int i=1;i<=n+1;i++)
	{
		while((!st.empty())&&(h[i]>=h[st.top()]))
		{
			ans=ans+i-st.top()-1;
			st.pop();
		}
		st.push(i);
	}
	printf("%lld\n",ans);
	return 0;
}