1. 程式人生 > 其它 >1003 Emergency (25分)——迪傑斯特拉模板題

1003 Emergency (25分)——迪傑斯特拉模板題

技術標籤:資料結構演算法連結串列dijkstrac++

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers:N(≤500) - the number of cities (and the cities are numbered from 0 toN−1),M- the number of roads,C​1​​andC​2​​- the cities that you are currently in and that you must save, respectively. The next line containsNintegers, where thei-th integer is the number of rescue teams in thei-th city. ThenMlines follow, each describes a road with three integersc​1​​,c​2​​andL, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path fromC​1​​toC​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths betweenC​1​​andC​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

程式碼

#include <iostream>
#include <string.h>
#include <math.h>

using namespace std;

const int INF = 999999;

struct edge
{
    int v;
    int dis=INF;
    int next=0;
};
int head[1000]= {0};


edge edges[10000];

int vis[1000]= {0};
int num[1000];
int in=0;
void addedge(int f,int t,int dis)
{
    in++;
    edges[in].dis=dis;
    edges[in].v=t;
    edges[in].next=head[f];
    head[f]=in;
    in++;
    edges[in].dis=dis;
    edges[in].v=f;
    edges[in].next=head[t];
    head[t]=in;
}

int dis[1000];
int discost[1000];
int minnum[1000]={0};
void dijkstra(int n,int u)
{
    for(int i=head[u]; i!=0; i=edges[i].next)
    {
        dis[edges[i].v]=edges[i].dis;
        discost[edges[i].v]=num[edges[i].v]+num[u];
        minnum[edges[i].v]=1;
    }
    vis[u]=1;
    dis[u]=0;
    minnum[u]=1;
    discost[u]=num[u];
    for(int i=0; i<n; i++)
    {
        int m=u;
        int temp=INF;
        for(int j=0; j<n; j++)
        {
            if(vis[j]==0&&dis[j]<temp)
            {
                m=j;
                temp=dis[j];
            }
        }
        if(m==u)
            break;
        vis[m]=1;
        for(int e = head[m]; e!=0; e=edges[e].next)
        {
            if(vis[edges[e].v]!=1&&dis[edges[e].v]==dis[m]+edges[e].dis)
            {
                if(discost[edges[e].v]<discost[m]+num[edges[e].v])
                    discost[edges[e].v]=discost[m]+num[edges[e].v];
                minnum[edges[e].v]+=minnum[m];
            }
            else if(vis[edges[e].v]!=1&&dis[edges[e].v]>dis[m]+edges[e].dis)
            {
                dis[edges[e].v]=dis[m]+edges[e].dis;
                discost[edges[e].v]=discost[m]+num[edges[e].v];
                minnum[edges[e].v]=minnum[m];
            }
        }
    }
}
int main()
{
    int n,m,u,v;
    cin>>n>>m>>u>>v;
    memset(dis,INF,sizeof(dis));
    memset(discost,0,sizeof(discost));
    memset(minnum,0,sizeof(minnum));
    for(int i=0; i<n; i++)
    {
        cin>>num[i];
    }
    for(int i=0; i<m; i++)
    {
        int u1,v1,c;
        cin>>u1>>v1>>c;
        addedge(u1,v1,c);
    }
    dijkstra(n,u);
    cout<<minnum[v]<<' '<<discost[v];
    return 0;
}