1. 程式人生 > 其它 >PAT A1019 General Palindromic Number (20分)

PAT A1019 General Palindromic Number (20分)

技術標籤:PAT記錄c語言資料結構

PAT A1019 General Palindromic Number (20分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑i=0​k(ai bi ). Here, as usual, 0≤ai <b for all i and ak is non-zero. Then N is palindromic if and only if a​​k =a​k−i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10^9​ is the decimal number and 2≤b≤10^​9 is the base. The numbers are separated by a space.

Output Specification:
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak​ a​k−1 … a0​​ ". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1

以下是AC的程式碼:

#include<cstdio>
#define maxn 40
int main(void){
	int base,N;
	int ans[maxn]={0};
	scanf("%d %d",&N,&base);
	int temp=N,i;
	for(i=0;temp>0;i++){
		ans[i]=temp%base;
		temp=temp/base;
	}
	bool Ispalin=true;
	for(int j=0;j<i/2;j++){
		if(ans[j] != ans[i-j-1]){
			Ispalin=false;
		}
	}
	if(!Ispalin) printf("No\n");
	else printf("Yes\n");
	for(int j=i-1;j>=0;j--){
		printf("%d",ans[j]);
		if(j!=0)printf(" ");
	}
	return 0;
}

思路:
經典判斷迴文的題。首先把數字N轉換為題目要求進位制下的數字N’,並且放到結果陣列ans[]中,設定bool變數Ispalin,設定為true,然後依次比對ans中的數字,有不同的就把Ispalin置為false,並且break出去。根據Ispalin值輸出Yes或者No,再將ans中數字倒序輸出即可。