矩陣轉置
阿新 • • 發佈:2021-01-20
題目
將一個2行3列的矩陣(二維陣列)行列互換,儲存到另一個3行2列的矩陣中。
要求以整型資料為例來解答。
Input
輸入2行資料,每行3個整數,以空格分隔。
Output
行列互換後的矩陣,3行,每行2個數據,以空格分隔。
Sample Input
1 2 3
4 5 6
Sample Output
1 4
2 5
3 6
##a[2][3]表示兩行三列
程式碼
#include<stdio.h>
int main()
{
int a[2][3],i,j, b[3][2];
for(i=0;i<2;i++){
for(j= 0;j<3;j++){
scanf("%d",&a[i][j]);
}
}
for(i=0;i<3;i++){
for(j=0;j<2;j++){
b[i][j]=a[j][i];
}
}
for(i=0;i<3;i++){
for(j=0;j<2;j++){
printf("%d ",b[i][j]);
}
printf("\n");
}
return 0;
}