1. 程式人生 > 其它 >HDU1087 Super Jumping! Jumping! Jumping! 最長上升子序列和 LIS(DP,二分+貪心)

HDU1087 Super Jumping! Jumping! Jumping! 最長上升子序列和 LIS(DP,二分+貪心)

技術標籤:演算法# 入門動態規劃演算法stlicpc二分法

HDU1087Super Jumping! Jumping! Jumping!最長上升子序列和 LIS(DP,二分+貪心)


Super Jumping! Jumping! Jumping!

題目連結

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 67616 Accepted Submission(s): 31625

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

在這裡插入圖片描述

The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

DP程式碼

#include <bits/stdc++.h>
using namespace std;

int t,a[1005];
long long dp[1005];
int main(){
	ios::sync_with_stdio(0),cin.tie(0),cout.tie(0);
	while(cin >> t && t){
		long long mmax=0LL;
		memset(dp,0,sizeof dp);
		for(int i=0;i<t;i++){
			cin >> a[i];dp[i]=a[i];
			for(int j=0;j<i;j++){
				if(a[i]>a[j])
				dp[i]=max(dp[j]+a[i],dp[i]);
			}
			mmax=max(mmax,dp[i]);
		}
		cout << mmax << endl;
	}
}

二分,貪心(O)