1. 程式人生 > 其它 >【實操】配置Telnet與SSH

【實操】配置Telnet與SSH

技術標籤:華為認證思科認證思科ccna網路工程師

實驗目的

1.理解Telnet與SSH的執行原理

2.掌握Telnet與SSH的配置方法

實驗拓撲

圖片

實驗需求

1、根據實驗拓撲圖,完成裝置的基本配置;

2、SW1允許R1通過Telnet遠端管理,VTY密碼為xmws;

3、R2允許R1通過SSH version2遠端管理,使用者名稱為xmws,密碼為wisdom,域名為xmws.cn。

實驗步驟

步驟1:裝置的基本配置

配置R1

Router>enable

Router#configure terminal

Router(config)#hostname R1

R1(config)#no ip domain-lookup

R1(config)#line console 0

R1(config-line)#exec-timeout 0 0

R1(config-line)#logging synchronous

R1(config-line)#exit

R1(config)#enable password xmws

R1(config)#interface ethernet0/0

R1(config-if)#ip address 192.168.1.254 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#interface ethernet0/1

R1(config-if)#ip address 192.168.12.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#end

R1#

配置R2

Router>enable

Router#configure terminal

Router(config)#hostname R2

R2(config)#no ip domain-lookup

R2(config)#line console 0

R2(config-line)#exec-timeout 0 0

R2(config-line)#logging synchronous

R2(config-line)#exit

R2(config)#enable password xmws

R2(config)#interface ethernet0/0

R2(config-if)#ip address 192.168.12.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#end

R2#

配置SW1

Switch>enable

Switch#configure terminal

Switch(config)#hostname SW1

SW1(config)#no ip domain-lookup

SW1(config)#line console 0

SW1(config-line)#exec-timeout 0 0

SW1(config-line)#logging synchronous

SW1(config-line)#exit

SW1(config)#enable password xmws //必須設定,否則Telnet上SW1後無法進入特權模式

SW1(config)#interface vlan 1

SW1(config-if)#ip address 192.168.1.1 255.255.255.0

SW1(config-if)#no shutdown

SW1(config-if)#exit

SW1(config)#ip default-gateway 192.168.1.254

SW1(config)#end

SW1#

步驟2:配置Telnet

配置SW1

SW1>enable

SW1#configure terminal

SW1(config)#line vty 0 4 //進入VTY

SW1(config-line)#password xmws //設定Telnet登入的密碼為xmws

SW1(config-line)#login //啟用密碼

SW1(config-line)#transport input telnet //允許通過Telnet遠端登入

SW1(config-line)#end

SW1#

步驟3:配置SSH

配置R2

R2>enable

R2#configure terminal

R2(config)#username xmws password wisdom //建立使用者名稱和密碼

R2(config)#ip ssh version 2 //啟用SSH版本2

R2(config)#ip domain-name xmws.cn //定義域名

R2(config)#crypto key generate rsa //生成金鑰

The name for the keys will be: R2.xmws.cn

Choose the size of the key modulus in the range of 360 to 4096 for your

General Purpose Keys. Choosing a key modulus greater than 512 may take

a few minutes.

How many bits in the modulus [512]:1024 //SSHv2金鑰長度至少768位

% Generating 1024 bit RSA keys, keys will be non-exportable...

[OK] (elapsed time was 0 seconds)

R2(config)#

R2(config)#line vty 0 4

R2(config-line)#login local //使用使用者名稱和密碼驗證

R2(config-line)# transport input ssh //允許通過SSH遠端登入

R2(config-line)#end

R2#

實驗檢查

步驟1:Telnet測試

R1#telnet 192.168.1.1Trying 192.168.1.1 ... OpenUser Access VerificationPassword:SW1>   //成功登入SW1
注意,如果SW1沒有設定Enable密碼,R1登入到SW1後輸Enable會出現如下提示:R1#telnet 192.168.1.1Trying 192.168.1.1 ... OpenUser Access VerificationPassword:SW1>enable% No password set
同時按<Ctrl+Shit+6>組合鍵,然後再按x把介面切回R1R1#show sessions   //檢視R1開啟的Telnet會話Conn Host                Address             Byte  Idle Conn Name*  1 192.168.1.1         192.168.1.1            6     5 192.168.1.1R1#resume 1   //重新連線到SW1[Resuming connection 1 to 192.168.1.1 ... ]SW1>

步驟2:檢查Telnet

SW1#show users   //SW1上檢視誰登入到自己Line User Host(s) Idle Location*  0 con 0  idle   00:00:00      2 vty 0  idle   00:02:47 192.168.1.254  Interface User   Mode        Idle     Peer AddressLocation表示是誰登入到自己,192.168.1.254是R1。SW1#clear line 2   //清除R1的Telnet連線[confirm] [OK]SW1#show users    Line       User       Host(s)              Idle       Location*  0 con 0                idle                 00:00:00     Interface    User               Mode         Idle     Peer AddressR1已經被清除。

步驟3:SSH測試

R1#ssh -l xmws 192.168.12.2

Password:

R2>enable

Password:

R2# //成功登入到R2

步驟4:檢查SSH

R2#show ssh Connection Version Mode Encryption Hmac State  Username0    1.99 IN aes128-ctr  hmac-sha2-256 Session started       xmws0    1.99 OUT aes128-ctr  hmac-sha2-256 Session started     xmws