Problem:平方矩陣 II
阿新 • • 發佈:2021-02-08
Problem Description
輸入整數N,輸出一個N階的二維陣列。
陣列的形式參照樣例。
Input Format
輸入包含多行,每行包含一個整數N。
當輸入行為N=0時,表示輸入結束,且該行無需作任何處理。
Output Format
對於每個輸入整數N,輸出一個滿足要求的N階二維陣列。
每個陣列佔N行,每行包含N個用空格隔開的整數。
每個陣列輸出完畢後,輸出一個空行。
Scope of Data
0 ≤ N ≤ 100
Sample Input
Sample Output
Idea
找規律
Program Code
#include <iostream>
using namespace std;
int n;
int main()
{
while(cin >> n && n)
{
for(int i = 1; i <= n; ++ i)
{
int x = i; //x作臨時變數
for(int j = 1; j <= n; ++ j)
{
if(i == j)
{
x = 1;
cout << x ++ << ' ';
continue;
}
if(i < j)
{
cout << x ++ << ' ';
continue;
}
if(i > j)
{
cout << x -- << ' ';
continue;
}
}
//另一種行、列數與數值的規律(x = i - j + 1)
/*
for(int j = 1; j <= n; ++j)
{
cout << abs(i - j) + 1 << ' ';
}
*/
cout << endl;
}
cout << endl;
}
return 0;
}
- If you have any questions,please feel free to communicate with me.