1. 程式人生 > 其它 >【LeetCode】930. 和相同的二元子陣列

【LeetCode】930. 和相同的二元子陣列

1006 Sign In and Sign Out (25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS

, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

思路

  1. 比較時間

程式碼

#include<stdio.h>
#include<string.h>
struct person{
	char ID_number[16];
	int hh1,mm1,ss1,hh2,mm2,ss2;
}tmp,unlocked,lock;

bool Early(person a, person b){
	if(a.hh1 != b.hh1) return a.hh1 < b.hh1;
	else if(a.mm1 != b.mm1) return a.mm1 < b.mm1;
	else return a.ss1 < b.ss1;
}

bool Later(person a, person b){
	if(a.hh2 != b.hh2) return a.hh2 > b.hh2;
	else if(a.mm2 != b.mm2) return a.mm2 > b.mm2;
	else return a.ss2 > b.ss2;
}

void init(){
	unlocked.hh1 = 23;
	lock.hh2 = lock.mm2 = lock.ss2 = 0;
	unlocked.mm1 = unlocked.ss1 = 59;
}

int main(){
	init();
	int m;
	scanf("%d", &m);
	for(int i = 0; i < m; i++){
		scanf("%s %d:%d:%d %d:%d:%d", tmp.ID_number, &tmp.hh1, &tmp.mm1, &tmp.ss1, &tmp.hh2, &tmp.mm2, &tmp.ss2);
		if(Early(tmp, unlocked)) unlocked = tmp;
		if(Later(tmp, lock)) lock = tmp;
	}
	printf("%s %s", unlocked.ID_number, lock.ID_number);
	return 0;
}

參考程式碼

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

struct pNode{
	char id[20];
	int hh,mm,ss;
}temp,ans1,ans2;

bool great(pNode node1, pNode node2){
	if(node1.hh != node2.hh) return node1.hh > node2.hh;
	if(node1.mm != node2.mm) return node1.mm > node2.mm;
	return node1.ss > node2.ss;
}

int main(){
	int n;
	scanf("%d", &n);
	ans1.hh = 24, ans1.mm = 60, ans1.ss = 60;
	ans2.hh = 0, ans2.mm = 0, ans2.ss  = 0;
	for(int i = 0; i < n; i++){
		scanf("%s %d:%d:%d", temp.id, &temp.hh, &temp.mm, &temp.ss);
		if(great(temp,ans1) == false) ans1 = temp;
		scanf("%d:%d:%d", &temp.hh, &temp.mm, &temp.ss);
		if(great(temp,ans2)== true) ans2 = temp;
	}
	printf("%s %s\n",ans1.id, ans2.id);
	return 0;
}

參考程式碼(柳婼大神)

將時間都轉換為總秒數,最早和最遲的時間儲存在變數minn和maxn中,並同時儲存當前最早和 最遲的⼈的ID,最後輸出

#include <iostream>
#include <climits>
using namespace std;
int main() {
    int n, minn = INT_MAX, maxn = INT_MIN;
    scanf("%d", &n);
    string unlocked, locked;
    for(int i = 0; i < n; i++) {
        string t;
        cin >> t;
        int h1, m1, s1, h2, m2, s2;
        scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
        int tempIn = h1 * 3600 + m1 * 60 + s1;
        int tempOut = h2 * 3600 + m2 * 60 + s2;
        if (tempIn < minn) {
            minn = tempIn;
            unlocked = t;
        }
        if (tempOut > maxn) {
            maxn = tempOut;
            locked = t;
        }
    }
    cout << unlocked << " " << locked;
    return 0;
}