1. 程式人生 > 其它 >2021“MINIEYE杯”中國大學生演算法設計超級聯賽(1)1009. KD-Graph(並查集)

2021“MINIEYE杯”中國大學生演算法設計超級聯賽(1)1009. KD-Graph(並查集)

Problem Description

Let’s call a weighted connected undirected graph of n vertices and m edges KD-Graph, if the
following conditions fulfill:

* n vertices are strictly divided into K groups, each group contains at least one vertice

* if vertices p and q ( p ≠ q ) are in the same group, there must be at least one path between p and q meet the max value in this path is less than or equal to D.

* if vertices p and q ( p ≠ q ) are in different groups, there can’t be any path between p and q meet the max value in this path is less than or equal to D.

You are given a weighted connected undirected graph G of n vertices and m edges and an integer K.

Your task is find the minimum non-negative D which can make there is a way to divide the n vertices into K groups makes G satisfy the definition of KD-Graph.Or −1if there is no such D exist.

Input

The first line contains an integer T (1≤ T ≤5) representing the number of test cases.
For each test case , there are three integers n,m,k(2≤n≤100000,1≤m≤500000,1≤k≤n) in the first line.
Each of the next m lines contains three integers u,v and c (1≤v,u≤n,v≠u,1≤c≤109) meaning that there is an edge between vertices u and v with weight c.

Output

For each test case print a single integer in a new line.

Sample Input

2
3 2 2
1 2 3
2 3 5
3 2 2
1 2 3
2 3 3

Sample Output

3
-1

比賽的時候沉迷於優化二分+可持久化01trie的暴力,放過了這個簽到題QAQ

整體就是執行一個類似克魯斯卡爾的過程,將邊權從小到大排序然後不斷取,若取出的邊的兩端點在同一個集合則無事;若不在同一個集合且合併前連通塊數 > k + 1則正常合併同時--連通塊數;若不在同一個集合且合併後連通塊數 == k + 1說明合併完這條邊後連通塊數為k且滿足所有塊內的邊<=D,因此可以暫時令D = 該邊權,同時合併以及--連通塊數;若不在同一個集合且合併後連通塊數 < k + 1,此時需要判斷該邊權是否<=D,若是說明取當前的D會讓一些權值<=D的邊在連通塊外,顯然這個D是不合法的,但如果不取這個D的話分出來的連通塊數必然小於k,因此此時就可以判斷無解了。

#include <bits/stdc++.h>
#define N 100005
#define M 5000005
using namespace std;
int n, m, k;
struct edge{
	int x, y, z;
} e[M];
bool cmp(edge a, edge b) {
	return a.z < b.z;
}
int fa[500005];
int get(int x) {
	if(x == fa[x]) return x;
	return fa[x] = get(fa[x]);
}
int main() {
	//freopen("1.in", "r", stdin);
	int t;
	cin >> t;
	while(t--) {
		scanf("%d%d%d", &n, &m, &k);
		for(int i = 1; i <= m; i++) {
			scanf("%d%d%d", &e[i].x, &e[i].y, &e[i].z);
		}
		for(int i = 1; i <= n; i++) fa[i] = i;
		sort(e + 1, e + m + 1, cmp);
		int conn = n;
		int D = 0x3f3f3f3f;
		bool flag = 1;
		if(k == n) {
			D = 0;
		}
		for(int i = 1; i <= m; i++) {
			if(D == 0) break;
			int x = e[i].x, y = e[i].y, z = e[i].z;
			int fx = get(x), fy = get(y);
			//cout << z << endl;
			if(fx == fy) {
				continue;
			} else {
				if(conn > k + 1) {
					 //不用管
				} else if(conn == k + 1) {
					D = z;
				} else {
					if(z <= D) {
						flag = 0;
					}
					break;
				}
				fa[fx] = fy;
				conn--;
			}
		}
		if(!flag || D == 0x3f3f3f3f) cout << -1 << endl;
		else cout << D << endl;
	}
	return 0;
}