1. 程式人生 > 其它 >PTA 翁愷 7-43 Shuffling Machine

PTA 翁愷 7-43 Shuffling Machine

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employautomatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at thei-th position isj, it means to move the card from positionito positionj. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integerK(20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
結尾無空行

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
結尾無空行 整體思路: times儲存迴圈次數,i,j用於迴圈,temp用於數值交換,陣列R儲存了輸入的隨機數列,陣列AB用於儲存後續變換的值,本來想只用一個數組內部賦值,但是破壞了原有的陣列結構,就不得不用兩個陣列相互賦值了。AB陣列中的初始值都是0-53.迴圈一次times - 1,其為偶數時A陣列往B陣列賦值,其為奇數時,B陣列往A陣列賦值,最後結果在A陣列中儲存。 到了輸出環節,就要用到迴圈中內嵌迴圈了。例如輸出樣例,A[6]=1,6代表的是第(6+1)張牌,為牌序,也就是S7,1代表的是順序排在第一。外迴圈的i代表順序,內迴圈的j代表牌序。內迴圈中不斷迴圈從小找到大即可。同時要注意到,題目中要求了結尾不能有空格,所以把最後一項單獨拿出來輸出,不加空格。 整體程式碼:
#include <stdio.h>

int main (void){
    int times = 0;  //重複次數
    scanf ("%d",&times);
    int i = 0,j = 0,temp = 0;
    int r[54] = {0}; //儲存隨機序列 
    int a[54] = {0}; //初始序列
    int b[54] = {0};
    
    for (i = 0;i < 54;++i)
    {
        scanf ("%d",&r[i]);
        a[i] = i + 1;
        b[i] = i + 1;
    }
    while (times > 0)
    {
        if (times %2 == 0)
        {
            for (i = 0;i < 54;++i)
            {
                temp = r[i];
                b[i] = a[temp - 1];
            }
        }
        if (times % 2 != 0)
        {
            for (i = 0;i < 54;++i)
            {
                temp = r[i];
                a[i] = b[temp - 1];
            }
        }
        times--;
    }
    for (i = 1;i < 54;++i)
    {
        for (j = 0;j < 54;++j)
        {
            if (a[j] == i)
            {
                if (j <= 12)
                    printf ("S%d ",j + 1);
                if (j > 12 && j <= 25)
                    printf ("H%d ",j - 12);
                if (j > 25 && j <= 38)
                    printf ("C%d ",j - 25);
                if (j > 38 && j <= 51)
                    printf("D%d ",j - 38);
                if (j > 51 && j <= 53)
                    printf ("J%d ",j - 51);
            }
        }
    }
    for (j = 0;j < 54;++j)
    {
        if (a[j] == 54)
        {
            if (j <= 12)
                 printf ("S%d",j + 1);
            if (j > 12 && j <= 25)
                 printf ("H%d",j - 12);
            if (j > 25 && j <= 38)
                 printf ("C%d",j - 25);
            if (j > 38 && j <= 51)
                 printf("D%d",j - 38);
            if (j > 51 && j <= 53)
                 printf ("J%d",j - 51);
        }
    }
    return 0;
}