1. 程式人生 > 其它 >1041 Be Unique (20 分)(hash雜湊)

1041 Be Unique (20 分)(hash雜湊)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

生詞

英文 解釋
lottery 彩票

題目大意:

給n個數字,按照讀入順序,哪個數字是第一個在所有數字中只出現一次的數字。如果所有數字出現都超過了一次,則輸出None

分析:

建立一個數組,儲存每個數字出現的次數,然後遍歷一遍輸入的順序看是否有出現次數為1的數字

原文連結:https://blog.csdn.net/liuchuo/article/details/52153050

題解

奇怪的是:v陣列用vector儲存後兩個測試用例會出現段錯誤。

#include <bits/stdc++.h>

using namespace std;
int v[100010],h[100010];
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n;
    //vector<int> v(n);
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&v[i]);
        h[v[i]]++;
    }
    for(int i=0;i<n;i++){
        if(h[v[i]]==1){
            printf("%d\n",v[i]);
            return 0;
        }
    }
    printf("None\n");
    return 0;
}

本文來自部落格園,作者:勇往直前的力量,轉載請註明原文連結:https://www.cnblogs.com/moonlight1999/p/15570127.html