1. 程式人生 > 實用技巧 >pat 1137

pat 1137

1137Final Grading(25分)

For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by 0 if G​mid−term​​>G​final​​, or G​final​​ will be taken as the final grade G. Here G​mid−term​​ and G​final​​ are the student's scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores G?p??'s; the second one contains M mid-term scores G?mid?term??'s; and the last one contains N final exam scores G?final??'s. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID G​p​​ G​mid−term​​ G​final​​ G

If some score does not exist, output "−" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qullified student.

Sample Input:

6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

Sample Output:

missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

題意:給定三組資料,分別是學生的程式設計成績、期中成績和期末成績。要求按最終分數從高到低輸出及格的學生,分數重複的按照名字排序。其中最終分數=期中分數*0.4+期末分數*0.6(如果期中分數大於期末),否則直接將期末成績作為最終成績。程式設計分數不足200的學生不計入統計。最後分數需要四捨五入到整數位。

思路:自定義結點node,node包括程式設計分數、期中分數和期末分數。輸入的時候如果程式設計分數>200則將這個學生的記錄插入map<string,node>,其中string記錄學生名字。當輸入期中和期末成績的時候,如果這個學生的姓名不存在map中,直接忽略。遍歷map,計算總成績,將總成績大於等於60的加入vector中,最後對vector排序輸出。

程式碼如下

#include<cstdio>
#include<iostream>
#include<vector>
#include<map>
#include<string>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;
struct node2{
    string name;
    int sP;
    int sM;
    int sN;
    int G;
}; 
struct node{
    int sP;
    int sM;
    int sN;
};
map<string,node> maps;
bool cmp(node2 a,node2 b){
    if(a.G!=b.G)
        return a.G>b.G;
    else
        return a.name<b.name;
}
int main(){
    int p,m,n;
    scanf("%d%d%d",&p,&m,&n);
    char name[200];
    int sP,sM,sN;
    for(int i=0;i<p;i++){
        scanf("%s %d",name,&sP);
        node temp;
        temp.sP=sP;
        temp.sM=temp.sN=-1;
        if(temp.sP>=200)
            maps.insert(make_pair(name,temp));

    }
    for(int i=0;i<m;i++){
        scanf("%s %d",name,&sM);
            if(maps.count(name)==1){
                maps[name].sM=sM;
            }
    }
    for(int i=0;i<n;i++){
        scanf("%s %d",name,&sN);
            if(maps.count(name)==1){
                maps[name].sN=sN;
            }    
    }
    vector<node2> v;
    for(map<string,node>::iterator it=maps.begin();it!=maps.end();it++){
            int total;
            if((*it).second.sM>(*it).second.sN){
                 total=round((*it).second.sM*0.4+(*it).second.sN*0.6);
            }
            else{
                 total=(*it).second.sN;
            }
            if(total>=60){
                node2 temp;
                temp.G=total;
                temp.sP=(*it).second.sP;
                temp.sM=(*it).second.sM;
                temp.sN=(*it).second.sN;
                temp.name=(*it).first;
                v.push_back(temp);
            }
        
    }
    sort(v.begin(),v.end(),cmp);
    for(int i=0;i<v.size();i++){
        printf("%s %d %d %d %d\n",v[i].name.c_str(),v[i].sP,v[i].sM,v[i].sN,v[i].G);
    }
    
}