1. 程式人生 > 實用技巧 >2020杭電HDU多校第二場The Oculus(假斐波那契數列真Hash)

2020杭電HDU多校第二場The Oculus(假斐波那契數列真Hash)

Problem Description

Let's define the Fibonacci sequence \(F_1,F_2,… as F_1=1,F_2=2,F_i=F_{i−1}+F_{i−2}\) (i≥3).

It's well known that every positive integer x has its unique Fibonacci representation $(b_1,b_2,…,b_n) $such that:

· \(b_1×F_1+b_2×F_2+⋯+b_n×F_n=x\).

· bn=1, and for each i (1≤i<n), bi∈{0,1} always holds.

· For each i (1≤i<n), bi×bi+1=0 always holds.

For example, 4=(1,0,1), 5=(0,0,0,1), and 20=(0,1,0,1,0,1) because \(20=F_2+F_4+F_6=2+5+13\).

There are two positive integers A and B written in Fibonacci representation, Skywalkert calculated the product of A and B and written the result C in Fibonacci representation. Assume the Fibonacci representation of C is \((b_1,b_2,…,b_n)\)

, Little Q then selected a bit k (1≤k<n) such that bk=1 and modified bk to 0.

It is so slow for Skywalkert to calculate the correct result again using Fast Fourier Transform and tedious reduction. Please help Skywalkert to find which bit k was modified.

Input
The first line of the input contains a single integer T (1≤T≤10000), the number of test cases.

For each case, the first line of the input contains the Fibonacci representation of A, the second line contains the Fibonacci representation of B, and the third line contains the Fibonacci representation of modified C.

Each line starts with an integer n, denoting the length of the Fibonacci representation, followed by n integers \(b_1,b_2,…,b_n\), denoting the value of each bit.

It is guaranteed that:

· 1≤|A|,|B|≤1000000.

· 2≤|C|≤|A|+|B|+1.

·∑|A|,∑|B|≤5000000.

Output
For each test case, output a single line containing an integer, the value of k.

Sample Input
1
3 1 0 1
4 0 0 0 1
6 0 1 0 0 0 1

Sample Output
4

emmm,題目是真的假。。。看起來唬人的一批,好像還要跑NTT來著。。。結果一個Hash就過去了。。。我們直接暴力計算A和B的值,然後乘一下,跟C的值進行比較就可以了。不過在這之前我們要把斐波那契的Hash值預處理處理。

以下是AC程式碼:

#include <bits/stdc++.h>
using namespace std;

typedef unsigned long long ull;

const int mac=1e6+10;

ull dp[mac*2];
int a[mac],b[mac],c[mac*2];

int main(int argc, char const *argv[])
{
	int t;
	dp[1]=1;dp[2]=2;
	for (int i=3; i<mac*2; i++)
		dp[i]=dp[i-1]+dp[i-2];
	scanf ("%d",&t);
	while (t--){
		int na,nb,nc;
		scanf ("%d",&na);
		for (int i=1; i<=na; i++)
			scanf ("%d",&a[i]);
		scanf ("%d",&nb);
		for (int i=1; i<=nb; i++)
			scanf ("%d",&b[i]);
		scanf ("%d",&nc);
		for (int i=1; i<=nc; i++)
			scanf ("%d",&c[i]);
		ull s1=0,s2=0,s3=0;
		for (int i=1; i<=na; i++)
			if (a[i]) s1+=dp[i];
		for (int i=1; i<=nb; i++)
			if (b[i]) s2+=dp[i];
		for (int i=1; i<=nc; i++)
			if (c[i]) s3+=dp[i];
		for (int i=1; i<=na+nb+1; i++){
			if (s3+dp[i]==s1*s2){
				printf("%d\n",i);
				break;
			}
		}
	}
	return 0;
}