1. 程式人生 > 其它 >hdu:FatMouse and Cheese(記憶化非線性dfs)

hdu:FatMouse and Cheese(記憶化非線性dfs)


Problem Description FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.  
Input There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.  
Output For each test case output in a line the single integer giving the number of blocks of cheese collected.  
Sample Input 3 1 1 2 5 10 11 6 12 12 7 -1 -1  
Sample Output 37 本題最核心在於搜尋使用的狀態為從該點出發所得的最優解,避免了直接處理的不確定性
附ac程式碼
#include<bits/stdc++.h>
using namespace std;
int num[110][110],ans[110][110],n,k;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
bool pd(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<n)
    return 1;
    else
    return 0;
}
int dfs(int x,int y)
{
    int answer=0;
    
if(ans[x][y]) return ans[x][y]; for(int i=1;i<=k;++i) { for(int j=0;j<4;++j) { int x1=x+dir[j][0]*i; int y1=y+dir[j][1]*i; if(pd(x1,y1)&&num[x1][y1]>num[x][y]) answer=max(answer,dfs(x1,y1)); } } ans[x][y]
=num[x][y]+answer; return ans[x][y]; } int main() { while(scanf("%d%d",&n,&k)==2&&n>0) { memset(ans,0,sizeof(ans)); for(int i=0;i<n;++i) for(int j=0;j<n;++j) { scanf("%d",&num[i][j]); } printf("%d\n",dfs(0,0)); } }