1. 程式人生 > >bzoj 1072狀壓DP

bzoj 1072狀壓DP

str () sample php output mes har sca inpu

1072: [SCOI2007]排列perm

Time Limit: 10 Sec Memory Limit: 128 MB
Submit: 2293 Solved: 1448
[Submit][Status][Discuss]

Description

  給一個數字串s和正整數d, 統計s有多少種不同的排列能被d整除(可以有前導0)。例如123434有90種排列能
被2整除,其中末位為2的有30種,末位為4的有60種。

Input

  輸入第一行是一個整數T,表示測試數據的個數,以下每行一組s和d,中間用空格隔開。s保證只包含數字0, 1
, 2, 3, 4, 5, 6, 7, 8, 9.

Output

  每個數據僅一行,表示能被d整除的排列的個數。

Sample Input

7
000 1
001 1
1234567890 1
123434 2
1234 7
12345 17
12345678 29

Sample Output

1
3
3628800
90
3
6
1398

HINT

在前三個例子中,排列分別有1, 3, 3628800種,它們都是1的倍數。

【限制】

100%的數據滿足:s的長度不超過10, 1<=d<=1000, 1<=T<=15

數據範圍 小 3 #include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[1029][1028],d;
int num[12],len,pt[18];
int tot[12],v[12];
char str[18];
void dp()
{
for(int i=0; i<=pt[len]; ++i)
for(int j=0; j<=d; ++j)
f[i][j]=0;
f[0][0]=1;
for(int i=0; i<pt[len]-1; ++i)
for(int j=0; j<d; ++j)
if(f[i][j])
{
for(int k=0; k<len; ++k)
if(((pt[k])&i)==0)
{
f[i|pt[k]][(j*10+num[k])%d]+=f[i][j];
}
}
}
int main()
{
int T;
pt[0]=1;
for(int i=1; i<=10; ++i) pt[i]=pt[i-1]<<1;
for(scanf("%d",&T); T--;)
{
scanf("%s%d",str,&d);
len=strlen(str);
for(int i=0; i<=9; ++i) tot[i]=0,v[i]=1;
for(int i=0; i<len; ++i)
{
num[i]=str[i]-‘0‘;
++tot[num[i]];
v[num[i]]*=tot[num[i]];
}
dp();
for(int i=0; i<=9; ++i) f[pt[len]-1][0]/=v[i];
printf("%d\n",f[pt[len]-1][0]);
}
}

bzoj 1072狀壓DP