1. 程式人生 > >HDU - 6011 Lotus and Characters

HDU - 6011 Lotus and Characters

row mathjax con contain cout har its XML nes

仔細讀題,然後來一發大模擬!

Lotus has nn kinds of characters,each kind of characters has a value and a amount.She wants to construct a string using some of these characters.Define the value of a string is:its first character‘s value*1+its second character‘s value *2+...She wants to calculate the maximum value of string she can construct.
Since it‘s valid to construct an empty string,the answer is always
0≥0。

InputFirst line is T(0T1000)T(0≤T≤1000) denoting the number of test cases.
For each test case,first line is an integer n(1n26)n(1≤n≤26),followed by nn lines each containing 2 integers vali,cnti(|vali|,cnti100)vali,cnti(|vali|,cnti≤100),denoting the value and the amount of the ith character.
OutputFor each test case.output one line containing a single integer,denoting the answer.
Sample Input

2
2
5 1
6 2
3
-5 3
2 1
1 1

Sample Output

35
5
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <vector>
using namespace std;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        vector<int> vec;
        int n;
        scanf("%d",&n);
        int allnum=0;
        for(int i=0;i<n;i++)
        {
            int val,num;
            scanf("%d%d",&val,&num);
            allnum+=num;
            while(num--)
            {
                vec.push_back(val);
            }
        }
        //代碼裏最重要的是dissum這個數,代表著ipos位置後面的數字各取一個的和
        sort(vec.begin(),vec.end());
        int ipos=0;
        long long int disnum=0;
        //int flag=1;
        for(int i=0;i<allnum;i++)
        {
            if(vec[i]<0)
            {
                ipos=max(ipos,i);
            }
            else if(vec[i]>=0)
            {
                disnum+=vec[i];
            }
        }
        //cout<<ipos<<endl;
        long long int ans=0;
        if(ipos!=0)
        {for(int i=ipos+1;i<allnum;i++)
        {
            ans+=vec[i]*(i-ipos);
        }
        while((vec[ipos]+disnum)>0&&ipos>=0)
        {
            ans+=(vec[ipos]+disnum);
            disnum+=vec[ipos];//dissum是會改變的ipos位置變化會引起這個的變化
            ipos--;
        }}
        else
        for(int i=0;i<allnum;i++)
        {
            ans+=vec[i]*(i+1);
        }
        //cout<<ans<<endl;

        printf("%lld\n",ans);
    }
}

  

HDU - 6011 Lotus and Characters