1. 程式人生 > >Balancing Act(樹的重心)

Balancing Act(樹的重心)

rest blog plm efi pro 中心 des != forest

傳送門
Balancing Act
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14070 Accepted: 5939

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:
技術分享

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

Source

POJ Monthly--2004.05.15 IOI 2003 sample task 【思路】 求樹的重心 樹的中心:刪掉這個點後,所形成的連通塊最大的最小。 dp[i]為刪掉這個點後最大的連通塊的值。 edge數組開小了runtime erroe 【code】
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,x,y,G,sumedge,t;
int head[20001],size[20001],dad[20001],dp[20001];
struct Edge
{
    int x,y,nxt;
    Edge(int x=0,int y=0,int nxt=0):x(x),y(y),nxt(nxt){}
}edge[40017];
void add(int x,int y)
{
    edge[++sumedge]=Edge(x,y,head[x]);
    head[x]=sumedge;
}
void init()
{
    sumedge=0;
    memset(head,0,sizeof(head));
    memset(size,0,sizeof(size));
    memset(dad,0,sizeof(dad));
    memset(dp,0,sizeof(dp));
    scanf("%d",&n);
    for(int i=1;i<n;i++)
    {
        scanf("%d%d",&x,&y);
        add(x,y);
        add(y,x);
    }
}
void dfs(int x)
{
    size[x]=1;
    for(int i=head[x];i;i=edge[i].nxt)
    {
        int v=edge[i].y;
        if(dad[x]!=v)
        {
            dad[v]=x;
            dfs(v);
            size[x]+=size[v];
            dp[x]=max(dp[x],size[v]);//最大的孩子 
        }
    }
    dp[x]=max(dp[x],n-size[x]);//不是子樹的那一堆 
}
void print()
{
    int ans=0x7fffff;
    for(int i=1;i<=n;i++)
    if(dp[i]<ans)ans=dp[i],G=i;
    printf("%d %d\n",G,ans);
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        init();
        dfs(1);
        print();
    }
    return 0;
}

Balancing Act(樹的重心)