1. 程式人生 > >[ACM] POJ 1068 Parencodings(模擬)

[ACM] POJ 1068 Parencodings(模擬)

rom 加密 algo scrip different name represent arch encoding

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19352 Accepted: 11675

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

Tehran 2001


解題思路:

題意為給一個僅僅包括括號的字符串加密有兩種方法:

方法一:用p數組表示。p[i]為第i個右括號左邊一共同擁有多少左括號

方法二:用w數組表示。w[i]表示當第i個括號左右匹配時,一共包含多少右括號

要求給定加密後的p數組,求出w數組。

能夠依據給的p數組先求出字符串s, p[i]-p[i-1]為第i個右括號緊跟在它前面的有多少個左括號。求出s

遍歷s,每次找到右括號,然後回溯,遇到右括號就計數(回溯前找到的那個也算)。直到遇到與它匹配的左括號(vis[]=0),由於一個右括號有唯一的左括號匹配,所以一旦找到它的左括號,就用vis[]=1標記下。

代碼:

#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;

int p[20],w[20];
bool vis[40];//註意範圍,題目中n<=20是n對括號,不是單個括號的個數.

int main()
{
    int t;cin>>t;
    int n;
    while(t--)
    {
        string s;
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>p[i];
        p[0]=0;
        for(int i=1;i<=n;i++)//構造s串
        {
            for(int j=1;j<=(p[i]-p[i-1]);j++)
                s+="(";
            s+=")";
        }
        int k=1;
        memset(vis,0,sizeof(vis));
        for(int i=0;i<2*n;i++)
        {
            int cnt=1;
            if(s[i]==')')//遇到右括號
            {
                for(int j=i-1;j>=0;j--)//回溯
                {
                    if(s[j]==')')
                        cnt++;
                    if(s[j]=='('&&!vis[j])//和小括號匹配
                    {
                        vis[j]=1;
                        break;
                    }
                }
                w[k++]=cnt;
            }
        }
        for(int i=1;i<=n;i++)
            cout<<w[i]<<" ";
        cout<<endl;
    }
    return 0;
}



[ACM] POJ 1068 Parencodings(模擬)