1. 程式人生 > >【POJ1068】Parencodings(模擬)

【POJ1068】Parencodings(模擬)

題目連結

Parencodings

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions:28556   Accepted: 16825

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 

	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

Tehran 2001

 

【題意】

給出一個序列P,代表每一個右括號前的左括號數目,要求輸出序列W,即每個右括號前能匹配的括號數目。

【解題思路】

用陣列b記錄每兩個右括號之間的左括號數目,然後依次匹配即可。

【程式碼】

#include<cstdio>
#include<cstring>
using namespace std;
int a[50],b[50],ans[50];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(ans,0,sizeof(ans));
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        b[0]=a[1];
        for(int i=1;i<n;i++)
            b[i]=a[i+1]-a[i];
        for(int i=1;i<=n;i++)
        {
            int j;
            for(j=i-1;j>=0;j--)
            {
                if(b[j]>0)
                {
                    b[j]--;
                    break;
                }
            }
            if(j>=0)ans[i]=i-j;
            else ans[i]=0;
        }
        for(int i=1;i<=n;i++)
            i==1?printf("%d",ans[i]):printf(" %d",ans[i]);
        printf("\n");
    }
    return 0;
}