1. 程式人生 > >Cipher

Cipher

ascii ble messages line ebr seq greate roc 不難

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

解題思路:

讀了半天才看懂題意。題目不難,但要靜下心去理解。

題目大意是先給一串數字, 再給一串信息。信息中的每一個字符與給的數字相相應,而相應的數字表示的是該字符應該出如今第幾個位置。

依據數字調整好字符的位置後相當於編碼一次。然後讓你求編碼k次後的信息是如何的。

這題必需要找出循環的節點。

字符在編碼m次後一定會回到原來的位置,這就是一個循環。記錄一個循環中每一個點的位置。編碼次數會給的非常大。

假設不用循環來做。是會超時的。

註意:這題每組數據輸出之間要空一行。

AC代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    int n, k, a[205], m[205][205], huan[205]; //m記錄一個循環中每一個節點。huan記錄每一個點多久循環一次
    char mes[205], ans[205];
    while(scanf("%d", &n) && n)
    {
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        while(scanf("%d", &k) && k)
        {
            gets(mes);
            for(int i = strlen(mes); i <= n; i++)
                mes[i] = ' ';
            memset(huan, 0, sizeof(huan));
            for(int i = 1; i <= n; i++)
            {
                int temp, j;
                temp = a[i];
                j = 1;
                m[i][j] = temp;
                while(a[temp] != a[i])
                {
                    temp = a[temp];
                    m[i][++j] = temp;  // 記錄循環中點的位置
                    huan[i]++;  //僅僅要沒有回到原來位置。循環長度加1
                }
                huan[i]++;
            }
            for(int i = 1; i <= n; i++)
            {
                int p, q;
                p = k % huan[i];  // 計算循環後的位置
                if(p)
                    q = m[i][p];
                else
                    q = m[i][huan[i]]; //若能整除說明循環到最後一個
                ans[q - 1] = mes[i];
            }
            ans[n] = '\0';
            printf("%s\n", ans);
        }
        printf("\n");  //每組數據之間要空一行
    }
    return 0;
}


Cipher