1. 程式人生 > >HDU-2896 病毒侵襲(AC自動機)

HDU-2896 病毒侵襲(AC自動機)

所有 build 我們 main init ane 哪些 nod class

病毒侵襲

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28843 Accepted Submission(s): 6662


Problem Description 當太陽的光輝逐漸被月亮遮蔽,世界失去了光明,大地迎來最黑暗的時刻。。。。在這樣的時刻,人們卻異常興奮——我們能在有生之年看到500年一遇的世界奇觀,那是多麽幸福的事兒啊~~
但網路上總有那麽些網站,開始借著民眾的好奇心,打著介紹日食的旗號,大肆傳播病毒。小t不幸成為受害者之一。小t如此生氣,他決定要把世界上所有帶病毒的網站都找出來。當然,誰都知道這是不可能的。小t卻執意要完成這不能的任務,他說:“子子孫孫無窮匱也!”(愚公後繼有人了)。
萬事開頭難,小t收集了好多病毒的特征碼,又收集了一批詭異網站的源碼,他想知道這些網站中哪些是有病毒的,又是帶了怎樣的病毒呢?順便還想知道他到底收集了多少帶病毒的網站。這時候他卻不知道何從下手了。所以想請大家幫幫忙。小t又是個急性子哦,所以解決問題越快越好哦~~

Input 第一行,一個整數N(1<=N<=500),表示病毒特征碼的個數。
接下來N行,每行表示一個病毒特征碼,特征碼字符串長度在20—200之間。
每個病毒都有一個編號,依此為1—N。
不同編號的病毒特征碼不會相同。
在這之後一行,有一個整數M(1<=M<=1000),表示網站數。
接下來M行,每行表示一個網站源碼,源碼字符串長度在7000—10000之間。
每個網站都有一個編號,依此為1—M。
以上字符串中字符都是ASCII碼可見字符(不包括回車)。

Output 依次按如下格式輸出按網站編號從小到大輸出,帶病毒的網站編號和包含病毒編號,每行一個含毒網站信息。
web 網站編號: 病毒編號 病毒編號 …
冒號後有一個空格,病毒編號按從小到大排列,兩個病毒編號之間用一個空格隔開,如果一個網站包含病毒,病毒數不會超過3個。
最後一行輸出統計信息,如下格式
total: 帶病毒網站數
冒號後有一個空格。

Sample Input 3 aaa bbb ccc 2 aaabbbccc bbaacc

Sample Output web 1: 1 2 3 total: 1

感覺AC自動機是個很神奇的數據結構,就像把字典樹和KMP算法結合到了一起一樣

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
using namespace std;
const int N = 210 * 500;
const int maxn = 128;
struct Aho_Corasick{
    int next[N][maxn], fail[N], data[N];
    int root, sz;
    int newnode(){
        for(int i = 0; i < maxn; i++) next[sz][i] = -1;
        data[sz] = -1;
        return sz++;
    }
    void Init() {sz = 0; root = newnode(); }

    void Insert(char *str, int v){
        int len = strlen(str), u = root;
        for(int i = 0; i < len; i++){
            if(next[u][str[i]] == -1)
                next[u][str[i]] = newnode();
            u = next[u][str[i]];
        }
        data[u] = v;
    }
    void Build(){
        queue<int> Q;
        fail[root] = root;
        for(int i = 0; i < maxn; i++){
            if(next[root][i] == -1) next[root][i] = root;
            else{
                fail[next[root][i]] = root;
                Q.push(next[root][i]);
            }
        }
        while(!Q.empty()){
            int u = Q.front(); Q.pop();
            for(int i = 0; i < 128; i++){
                if(next[u][i] == -1) next[u][i] = next[fail[u]][i];
                else{
                    fail[next[u][i]] = next[fail[u]][i];
                    Q.push(next[u][i]);
                }
            }
        }
    }
    vector<int> res;
    bool Query(char *str, int v){
        int len = strlen(str), u = root;
        res.clear();
        for(int i = 0; i < len; i++){
            u = next[u][str[i]];
            int tmp = u;
            while(tmp != root){
                if(data[tmp] != -1){
                    res.push_back(data[tmp]);
                }
                tmp = fail[tmp];
            }
        }
        if(!res.size()) return false;
        sort(res.begin(), res.end());
        printf("web %d:", v);
        for(int i = 0; i < res.size(); i++) printf(" %d", res[i]);
        printf("\n");
        return true;
    }

}AC;
char str[10010];

int main(){
    int n,m;
    scanf("%d",&n);
    AC.Init();
    for(int i=1;i<=n;i++){
        scanf("%s",str);
        AC.Insert(str,i);
    }
    AC.Build();
    int ans=0;
    scanf("%d",&m);
    for(int i=1;i<=m;i++){
        scanf("%s",str);
        if(AC.Query(str,i)) ans++;
    }
    printf("total: %d\n",ans);
    return 0;
}

  

HDU-2896 病毒侵襲(AC自動機)