1. 程式人生 > >2017ICPC/廣西邀請賽1005(水)HDU6186

2017ICPC/廣西邀請賽1005(水)HDU6186

clu pac for mes view sci n-n code algorithm

CS Course

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 593 Accepted Submission(s): 288


Problem Description Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers a技術分享1技術分享,a技術分享2技術分享,?,a技術分享n技術分享技術分享
, and some queries.

A query only contains a positive integer p, which means you
are asked to answer the result of bit-operations (and, or, xor) of all the integers except a技術分享p技術分享技術分享 .

Input There are no more than 15 test cases.

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2n,q10技術分享5技術分享技術分享


Then n non-negative integers a技術分享1技術分享,a技術分享2技術分享,?,a技術分享n技術分享技術分享 follows in a line, 0a技術分享i技術分享10技術分享9技術分享技術分享 for each i in range[1,n].

After that there are q positive integers p技術分享1技術分享,p技術分享2技術分享,?,p技術分享q技術分享技術分享 in q lines, 1p技術分享i技術分享n技術分享 for each i in range[1,q].

Output For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except a技術分享p技術分享技術分享
in a line.

Sample Input 3 3 1 1 1 1 2 3 Sample Output 1 1 0 1 1 0 1 1 0 題意 求n個整數(除去) 二進制位運算 和 或 異或的結果 解析 求出前後綴詢問時直接前綴後綴計算 AC代碼
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <string>
#include <queue>
#include <vector>
using namespace std;
const int maxn= 1e5 + 10;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int n,m;
int sum1[maxn],sum2[maxn],sum3[maxn];
int rsum1[maxn],rsum2[maxn],rsum3[maxn];
int a[maxn];
int main(int argc, char const *argv[])
{
    while(scanf("%d %d",&n,&m)==2)
    {
        scanf("%d",&a[1]);
        sum1[1]=sum2[1]=sum3[1]=a[1];
        for(int i=2;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum1[i]=sum1[i-1] & a[i];
            sum2[i]=sum2[i-1] | a[i];
            sum3[i]=sum3[i-1] ^ a[i];
        }
        rsum1[n]=rsum2[n]=rsum3[n]=a[n];
        for(int i=n-1;i>=1;i--)
        {
            rsum1[i]=rsum1[i+1] & a[i];
            rsum2[i]=rsum2[i+1] | a[i];
            rsum3[i]=rsum3[i+1] ^ a[i];
            //cout<<rsum1[i]<<" "<<rsum2[i]<<" "<<rsum3[i]<<endl;
        }
        int q;
        while(m--)
        {
            scanf("%d",&q);
            if(q==1)
                printf("%d %d %d\n",rsum1[2],rsum2[2],rsum3[2]);
            else if(q == n) 
                printf("%d %d %d\n",sum1[n-1],sum2[n-1],sum3[n-1]);  
            else 
                printf("%d %d %d\n",sum1[q-1] & rsum1[q+1],sum2[q-1]|rsum2[q+1],sum3[q-1]^rsum3[q+1]);
        }
    }
    return 0;
}

2017ICPC/廣西邀請賽1005(水)HDU6186