1. 程式人生 > >poj1006 生理周期

poj1006 生理周期

poj for 感情 累加 整數 pri space += 情況

生理周期
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 138947 Accepted: 44597

Description

人生來就有三個生理周期,分別為體力、感情和智力周期,它們的周期長度為23天、28天和33天。每一個周期中有一天是高峰。在高峰這天,人會在相應的方面表現出色。例如,智力周期的高峰,人會思維敏捷,精力容易高度集中。因為三個周期的周長不同,所以通常三個周期的高峰不會落在同一天。對於每個人,我們想知道何時三個高峰落在同一天。對於每個周期,我們會給出從當前年份的第一天開始,到出現高峰的天數(不一定是第一次高峰出現的時間)。你的任務是給定一個從當年第一天開始數的天數,輸出從給定時間開始(不包括給定時間)下一次三個高峰落在同一天的時間(距給定時間的天數)。例如:給定時間為10,下次出現三個高峰同天的時間是12,則輸出2(註意這裏不是3)。

Input

輸入四個整數:p, e, i和d。 p, e, i分別表示體力、情感和智力高峰出現的時間(時間從當年的第一天開始計算)。d 是給定的時間,可能小於p, e, 或 i。 所有給定時間是非負的並且小於365, 所求的時間小於21252。

當p = e = i = d = -1時,輸入數據結束。

Output

從給定時間起,下一次三個高峰同天的時間(距離給定時間的天數)。

采用以下格式:
Case 1: the next triple peak occurs in 1234 days.

註意:即使結果是1天,也使用復數形式“days”。

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source

East Central North America 1999

Translator

北京大學程序設計實習2007, Xie Di 分析:其實非常顯然,這道題是用中國剩余定理做的,而且三個周期是互質的,不用特殊處理.關於中國剩余定理可以看:oi初級數學知識.
這是我第一次用中國剩余定理做題,也出現了一些問題,答案最後處理出來可能是負數,我們需要不斷的加上模數直到變成正數,或者答案小於d,我們也需要累加直到大於d.其實我感覺吧,用擴展歐幾裏得解出來需要取模的題一般都有可能涉及到負數的情況,例如noip2012同余方程,要討論一下.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

const int mod = 21252;

int d,a[4];
int cnt = 0,ans,M;
int m[4] = {0,23,28,33};

void exgcd(int a,int b,int &x,int &y)
{
    if (!b)
    {
        x = 1;
        y = 0;
        return;
    }
    exgcd(b,a % b,x,y);
    int t = x;
    x = y;
    y = t - (a / b) * y;
    return;
}

void china()
{
    ans = 0,M = 1;
    for (int i = 1; i <= 3; i++)
    M *= m[i];
    for (int i = 1; i <= 3; i++)
    {
        int mi = M / m[i];
        int x,y;
        exgcd(mi,m[i],x,y);
        ans = (ans + a[i] * mi * x) % M;
    }
    if (ans < 0)
    ans += M;
}

int main()
{
    while (scanf("%d%d%d%d",&a[1],&a[2],&a[3],&d) && a[1] >= 0 && a[2] >= 0 && a[3] >= 0 && d >= 0)
    {
        cnt++;
        china();
        if (ans <= d)
        ans += mod;
        ans -= d;
        printf("Case %d: the next triple peak occurs in %d days.\n",cnt,ans);
    }
    
    return 0;
 } 

poj1006 生理周期