1. 程式人生 > >1060. Are They Equal (25)

1060. Are They Equal (25)

assume put include note sig ppi push chang terms

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
vector<char>va;
vector<char>vb;
int n;
vector<char> change(char s[],int &index){
	index=0;
	int flag=1;
	vector<char>tmp;
	if(!(s[0]==0&&s[1]==‘.‘)){
		tmp.push_back(‘0‘);
		tmp.push_back(‘.‘);		
	}
	int len=strlen(s);
	int j;
	for(j=0;j<len;j++){
		if(s[j]!=‘0‘)break;
	}
	for(int i=j;i<len;i++){
		if(s[i]!=‘.‘){
			tmp.push_back(s[i]);
			if(flag==1){
				index++;
			}
		}else{
			flag=0;
		}
	} 
	for(j=tmp.size();j<n+2;j++){
		tmp.push_back(‘0‘);
	}
	return tmp;
}
int main(){
	char a[120],b[120];
	scanf("%d %s %s",&n,a,b);
	//printf("%d %s %s",n,a,b);
	int aindex,bindex;
	va=change(a,aindex);
	//cout<<va.size()<<endl;
	//int aindex=index;
	vb=change(b,bindex);
	//int bindex=index;
	int flag=0;
	for(int i=0;i<n+2;i++){
		if(va[i]!=vb[i]){
			flag=1;
			break;
		}
	}
	if(flag==0){
		printf("YES ");
		for(int i=0;i<n+2;i++){
			printf("%c",va[i]);
		}
		printf("*10^%d\n",aindex);
	}else {
		printf("NO ");
		for(int i=0;i<n+2;i++){
			printf("%c",va[i]);
		}
		printf("*10^%d ",aindex);
		for(int i=0;i<n+2;i++){
			printf("%c",vb[i]);
		}
		printf("*10^%d\n",bindex);
	}
	return 0;
} 

  

還有一個錯誤點

技術分享



1060. Are They Equal (25)