1. 程式人生 > >1079. Total Sales of Supply Chain (25)

1079. Total Sales of Supply Chain (25)

tdi there 1.0 customer exc med file tin empty

A supply chain is a network of retailers(零售商), distributors(經銷商), and suppliers(供應商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID‘s are numbered from 0 to N-1, and the root supplier‘s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID‘s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj

. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4


解題思路:本題主要是利用鄰接表來對供應鏈關系的記錄,如圖1所示,所給測試例子中,用一個vector來記錄每個供應鏈中的價格分布(原價假設為0),0->2,時,2的價格變為0的1.01倍(r==0.01),當1->9時,9的價格為1的1.01倍,但由於此時1的價格未定,所以利用鄰接表先存儲1->9的關系,單5->1時,1的價格確定了,即可利用鄰接表對和1臨接的進行更新,更新9的價格為1.03:

技術分享圖片

圖 1

#include<iostream>
#include<cstdio>
#include<vector>
#include<map>
using namespace std;
struct Node{
	vector<int>next;
};
vector<double>price;
map<int,int>result;
vector<Node>vt;
void update(int num,int r){
	if(vt[num].next.empty())return;
	if(result.find(num)!=result.end())return ;
	vector<int>cur=vt[num].next;
	int size=cur.size();
	for(int i=0;i<size;i++){
		price[cur[i]]=price[num]*(1+r*1.0/100);
		update(cur[i],r);
	}
}
int main(){
	int n;
	double p,r;
	scanf("%d%lf%lf",&n,&p,&r);
	price.resize(n);
	vt.resize(n);
	int i,j;
	int num;
	price[0]=p;
	for(i=0;i<n;i++){
		scanf("%d",&j);
		if(j==0){
			scanf("%d",&num);
			result.insert(make_pair(i,num));
		}else{
			while(j--){
				scanf("%d",&num);
				vt[i].next.push_back(num);
				price[num]=price[i]*(1+r*1.0/100);
				update(num,r);			
			}
		}
	}
	double sum=0;
	for(map<int,int>::iterator it=result.begin();it!=result.end();it++){
		sum=sum+price[it->first]*it->second;
	}
	printf("%.1lf\n",sum);
	return 0;
}

  

1079. Total Sales of Supply Chain (25)