1. 程式人生 > >PAT-1137. Final Grading (25)

PAT-1137. Final Grading (25)

sig 用例 max using it is iss printf course int

1137. Final Grading (25)

時間限制 100 ms 內存限制 65536 kB 代碼長度限制 16000 B 判題程序 Standard 作者 CHEN, Yue

For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G = (Gmid-term

x 40% + Gfinalx 60%) if Gmid-term > Gfinal, or Gfinal will be taken as the final grade G. Here Gmid-term and Gfinal are the student‘s scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores Gp‘s; the second one contains M mid-term scores Gmid-term‘s; and the last one contains N final exam scores Gfinal‘s. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID Gp Gmid-term Gfinal G

If some score does not exist, output "-1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID‘s. It is guaranteed that the StudentID‘s are all distinct, and there is at least one qualified student.

Sample Input:
6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81
Sample Output:
missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

提交代碼

剛開始做,只得了4分,後來發現是cmp的返回值沒有寫全。

然後就是超時錯誤,這道題通過條件優化可以做到通過,還是感到新奇的,過去做ACM只要大方向沒有問題,都能過的,這道題一些條件沒有進行判斷,在運行時間上還是有很大差別的,可能是測試用例比較特別,也可能是pat時限要求很高。

#include <bits/stdc++.h>

using namespace std;

int N, M, K;

struct Stu {
    int online = -1;
    int mid = -1;
    int fina = -1;
    int tot = -1;
    string s;
    bool operator < (const Stu &stu) const {
        return tot == stu.tot ? s < stu.s : tot > stu.tot;
    }
};

map<string, Stu> stuMap;
vector<Stu> stuVec;

int main()
{
    cin>> N>> M>> K;
    string s;
    int x;
    for(int i = 0; i < N; i++) {
        cin>>s;
        scanf("%d", &x);
        if(x >= 200) {
            stuMap[s].s = s;
            stuMap[s].online = x;
        }
    }
    for(int i = 0; i < M; i++) {
        cin>>s;
        scanf("%d", &x);
        if(stuMap.count(s)) {
            stuMap[s].mid = x;
        }
    }
    for(int i = 0; i < K; i++) {
        cin>>s;
        scanf("%d", &x);
        if(stuMap.count(s)) {
            stuMap[s].fina = x;
            if(stuMap[s].mid > stuMap[s].fina) {
                stuMap[s].tot = stuMap[s].mid*0.4+stuMap[s].fina*0.6+0.5;
            }
            else {
                stuMap[s].tot = stuMap[s].fina;
            }
            if(stuMap[s].tot >= 60)stuVec.push_back(stuMap[s]);
        }
    }
    sort(stuVec.begin(), stuVec.end());
    for(int i = 0; i < stuVec.size(); i++) {
        printf("%s %d %d %d %d\n", stuVec[i].s.c_str(), stuVec[i].online, stuVec[i].mid, stuVec[i].fina, stuVec[i].tot);
    }
    return 0;
}

這是懸掛在超時邊緣的代碼:

#include <bits/stdc++.h>

using namespace std;

int N, M, K;

struct Stu {
    int online = -1;
    int mid = -1;
    int fina = -1;
    int tot = -1;
    //string s;
    /*bool operator < (const Stu &stu) const {
        return tot == stu.tot ? s < stu.s : tot > stu.tot;
    }*/
};

map<string, Stu> stuMap;
//vector<Stu> stuVec;
string stuNames[10004];

bool cmp(string s1, string s2) {
    return stuMap[s1].tot == stuMap[s2].tot ? s1 < s2 : stuMap[s1].tot > stuMap[s2].tot;
}

int main()
{
    cin>> N>> M>> K;
    string s;
    int x;
    for(int i = 0; i < N; i++) {
        cin>>s>>x;
        //if(x >= 200) {
            //stuMap[s].s = s;
            stuMap[s].online = x;
            stuNames[i] = s;
        //}
    }
    for(int i = 0; i < M; i++) {
        cin>>s>>x;
        //if(stuMap.count(s)) {
            stuMap[s].mid = x;
        //}
    }
    for(int i = 0; i < K; i++) {
        cin>>s>>x;
        //if(stuMap.count(s)) {
            stuMap[s].fina = x;
            if(stuMap[s].mid > stuMap[s].fina) {
                stuMap[s].tot = stuMap[s].mid*0.4+stuMap[s].fina*0.6+0.5;
            }
            else {
                stuMap[s].tot = stuMap[s].fina;
            }
            //if(stuMap[s].tot >= 60 && stuMap[s].online >= 200)stuVec.push_back(stuMap[s]);
        //}
    }
    sort(stuNames, stuNames+N, cmp);
    //sort(stuVec.begin(), stuVec.end());
    for(int i = 0; i < N; i++) {
        if(stuMap[stuNames[i]].online < 200) continue;
        if(stuMap[stuNames[i]].tot < 60) break;
        printf("%s %d %d %d %d\n", stuNames[i].c_str(), stuMap[stuNames[i]].online, stuMap[stuNames[i]].mid, stuMap[stuNames[i]].fina, stuMap[stuNames[i]].tot);
    }
    return 0;
}

PAT-1137. Final Grading (25)