PAT 1010 Radix (25 分)
1010 Radix (25 分)
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number. Now for any pair of positive integers N1and N2 , your task is to find the radix of one number while that of the other is given. Input Specification: Each input file contains one test case. Each case occupies a line which contains 4 positive integers: N1 N2 tag radix Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2. Output Specification: For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix. Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
解析
#include<iostream>
#include<cstdio>
#include<cctype>
#include<vector>
#include<string>
#include<algorithm>
#include<map>
using namespace std;
const string out = "Impossible" ;
map<char, int> mapp;
long long radix2dec(const string& temp,int radix)
{
long long sum=0,product=1;
for(int i=temp.size()-1;i>=0;i--){
sum = sum + mapp[temp[i]]*product;
product *= radix;
}
return sum;
}
int main()
{
for (int i = 0; i < 10; i++)
mapp[i + '0'] = i;
for (char i = 'a'; i <= 'z'; i++)
mapp[i] = i - 'a'+10;
string str_num1, str_num2;
int tag, radix;
cin >> str_num1 >> str_num2 >> tag >> radix;
if (tag == 2)
swap(str_num1, str_num2);
if (str_num1 == str_num2)
cout << radix;
else {
long long num1 = radix2dec(str_num1, radix), num2;
auto it = max_element(str_num2.begin(), str_num2.end());
long long low = (isdigit(*it)?*it-'0':*it-'a'+10)+1, high = max(num1,low);
while (low <= high) {
int mid = (low + high) / 2;
num2 = radix2dec(str_num2, mid);
if (num1 == num2) {
cout << mid;
return 0;
}
else if(num2>num1 || num2<0)
high = mid - 1;
else
low = mid + 1;
}
cout << out;
}
return 0;
}