1. 程式人生 > >PAT 1003

PAT 1003

any dfs follow ios pac quic numbers esc line

1003. Emergency (25)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4



圖典型的最短路徑問題。從城市C1出發,目的地C2,第一要求是路徑最短,其次是路徑上各點上的man之和最大,
輸出的是最短路徑的條數和man之和最大數

思路:

先構建鄰接矩陣edges,這裏需要給edge初始一個無窮大數值,忘記了c怎麽給一個數組每個元素設初值的函數調用,所以將edge定義為一個結構體,有兩個成員變量,一個表示是否可到達,一個表示距離。

另外設置一個marked數組記錄每個城市點是否被訪問過

struct edge{
    bool can_reach;
    int length;
    edge(){ can_reach = false; }
};
edge edges[505][505];
bool marked[505] = {false};

具體代碼:

#include <iostream>
#include <algorithm>
#include <climits>
using namespace std;
int city_hands[505] = {0};
struct edge{
    bool can_reach;
    int length;
    edge(){ can_reach = false; }
};
edge edges[505][505];
bool marked[505] = {false};
int min_path = INT_MAX;
int max_hands = INT_MIN;
int num = 0;
int N_cities,M_roads,C1,C2;
void dfs(int cur_city,int len,int hands)
{
    if(min_path<len)    return;
    if(cur_city==C2){
        if(min_path>len){
            num = 1;
            min_path = len;
            max_hands = hands;
        }
        else if(min_path==len){
            num ++;
            if(max_hands<hands) max_hands = hands;
        }
        return;
    }
    for(int i=0;i<N_cities;i++){
        if(marked[i]==false&&edges[cur_city][i].can_reach==true){
            marked[i] = true;
            dfs(i,len+edges[cur_city][i].length,hands+city_hands[i]);
            marked[i] = false;
        }
    }
    return;
}
int main()
{
    cin >> N_cities >> M_roads >> C1 >> C2;
    for(int i=0;i<N_cities;i++) cin>>city_hands[i];
    for(int i=0;i<M_roads;i++){
        int a,b,l;
        cin>>a>>b>>l;
        edges[a][b].can_reach = true;
        edges[a][b].length = l;
        edges[b][a].can_reach = true;
        edges[b][a].length = l;
    }
    marked[C1] = true;
    dfs(C1,0,city_hands[C1]);
    cout<<num<<" "<<max_hands<<endl;
    return 0;
}

PAT 1003