1. 程式人生 > >foj 2111 Problem 2111 Min Number

foj 2111 Problem 2111 Min Number

any mini scan small and center nal oid base

Problem 2111 Min Number

Accept: 1025 Submit: 2022
Time Limit: 1000 mSec Memory Limit : 32768 KB

技術分享圖片 Problem Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits (‘0‘-‘9‘). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

技術分享圖片 Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

技術分享圖片 Output

For each test case, output the minimum number we can get after no more than M operations.

技術分享圖片 Sample Input

3 9012 0 9012 1 9012 2

技術分享圖片 Sample Output

9012 1092 1029 思路:貪心模擬,頭部盡量與尾部的最小值交換。 AC代碼:
#include <iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#include<queue>
#include<string>
using namespace std;
#define N_MAX 10000+10
#define V_MAX 1000+10
#define INF 0x3f3f3f3f
int m;
string n;
void change(string &s,int n){//當前調整s的第n位
    char c=9+1;int id;
  for(int i=s.size()-1;i>n;i--){
     if(c>s[i]){
        if(n==0&&s[i]==0)continue;
        c=s[i];id=i;
      }
  }
  if(c<s[n])swap(s[n],s[id]);
}
int main(){
    int t;scanf("%d",&t);
    while(t--){
       cin>>n>>m;
       int cnt=0;
       string s;
       while(m){
            s=n;
       while(s==n&&cnt<s.size()-1){
        change(n,cnt);
          cnt++;
       }
       if(cnt>=s.size()-2)break;//已經不需要交換了
       m--;
       }
       cout<<n<<endl;
    }
    return 0;
}

foj 2111 Problem 2111 Min Number