1. 程式人生 > >poj 3069 Saruman's Army

poj 3069 Saruman's Army

劃分 一個 ont int arch mis minion mem 技術分享

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13285 Accepted: 6659

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R

units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x

1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

Stanford Local 2006 給出r和n,r是palantir能覆蓋的範圍,n是troop個數,要求用最少的palantir,使得每個軍隊都會在掌握之中。 貪心思想,首先按照位置對n個數從小到大排序,palantir按在的位置j應當保證他左邊有盡可能多的尚且沒有被前一個palantir覆蓋的troop,都能被他覆蓋,然後右邊能被他覆蓋的troop統統劃分給他。循環這樣的操作。 技術分享圖片
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#define MAX 1002
using namespace std;
int s[MAX],n,r;
int main()
{
    while(~scanf("%d%d",&r,&n) && r != -1 && n != -1)
    {
        for(int i = 0;i < n;i ++)
        {
            scanf("%d",&s[i]);
        }
        sort(s,s + n);
        int c = 0,i = 0;
        while(i < n)
        {
            c ++;
            int j = i;
            while(j + 1 < n && s[j + 1] - s[i] <= r)j ++;
            i = j;
            while(j + 1 < n && s[j + 1] - s[i] <= r)j ++;
            i = j + 1;
        }
        printf("%d\n",c);
    }
}
View Code

poj 3069 Saruman's Army