1. 程式人生 > >Saruman's Army POJ - 3069

Saruman's Army POJ - 3069

Saruman's Army
Time Limit: 1000MS         Memory Limit: 65536K
Total Submissions: 5742         Accepted: 2942
Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output

2
4
Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

 

  • 給出數軸上的一些點代表可放置的位置,給出裝置的覆蓋範圍(覆蓋的半徑)
  • 求出最少用多少個裝置能把所有給出的位置全部覆蓋..........
  • 貪心問題
  • 從一個未覆蓋的位置向前遍歷,找到滿足距離小於 r 的最右邊的點,
  • 這個點一定作為一個裝置的放置位置,然後從這個位置找到右邊的最小的不能覆蓋到的位置,
  • 這個位置作為下一次的起點...迴圈下去,直到所有的點都被覆蓋到
  • #include <iostream>
    #include<stdio.h>
    #include<algorithm>
    #include<string.h>
    using namespace std;
    const int maxn=1010;
    int a[maxn];
    int r,n;
    void pre()
    {
        int ans=0,i=0;
        while(i<n)
        {
            int s=a[i++];
            while(i<n&&a[i]<=s+r)i++;//左邊
            int p=a[i-1];
            while(i<n&&a[i]<=p+r)i++;//右邊
            ans++;
        }
        printf("%d\n",ans);
    }
    int main()
    {
        while(~scanf("%d%d",&r,&n))
        {
            if(r==-1&&n==-1)
                break;
            for(int i=0; i<n; i++)
                scanf("%d",&a[i]);
            sort(a,a+n);
            pre();
        }
        return 0;
    }