1. 程式人生 > >POJ 1979 Heavy Transportation (kruskal)

POJ 1979 Heavy Transportation (kruskal)

max i++ ret sport eth ecif cit scenario \n

          Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions:46898 Accepted: 12204

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo‘s place) to crossing n (the customer‘s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

題意:
有一個什麽東西要運到什麽地方去,可是不知道道路有沒有這麽大的承載力,所以問從1到n路徑的最小值中的最大值是多少。
思路
用kruskal建樹,知道1和n在一個集合中為止。
代碼
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct node
{
    int x,y,dis;
}e[100024];
int f[100024];
int n,m;

bool cmp(node x,node y)
{
    return x.dis>y.dis;
}

int getf(int t)
{
    if(f[t]==t){
        return t;
    }
    return f[t]=getf(f[t]);
}

void Merge(int x,int y)
{
    int t1=getf(x);
    int t2=getf(y);
    if(t1!=t2){
        f[t2]=t1;
    }
}

bool jud(int x,int y)
{
    int t1=getf(x);
    int t2=getf(y);
    if(t1==t2){return true;}
    else return false;
}

int kruskal()
{
    sort(e+1,e+m+1,cmp);
    for(int i=1;i<=n;i++){
        f[i]=i;
    }
    for(int i=1;i<=m;i++){
        Merge(e[i].x,e[i].y);
        if(jud(1,n)){return e[i].dis;}
    }
    return 0;

}


int main()
{
    int T;
    int y=0;
    scanf("%d",&T);
    while(T--){
        y++;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++){
            scanf("%d%d%d",&e[i].x,&e[i].y,&e[i].dis);
        }
        printf("Scenario #%d:\n%d\n\n",y,kruskal());
    }
}

 

POJ 1979 Heavy Transportation (kruskal)