1. 程式人生 > >Heavy Transportation (Dijkstra演算法變形)

Heavy Transportation (Dijkstra演算法變形)

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

題意:有n個城市,m條道路,在每條道路上只有一個承載量,要求從1到n的最大承載量,最大承載量就是所有通路的最大承載量

比如:1->2  3;  2->3 5  ,那麼1->3最大承載量為3 

思路:首先找到和1相連的的點u和載重量最大值maxn,然後找出manx 和與u相連的點i之間的重量的最小值ans,最後拿這個最小值與dis[i]相比,如果ans>dis[i],則需要更新,反覆進行這個過程,知道外層迴圈結束

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int n,m;
#define Inf 0x3f3f3f3f
const int N=1005;
int g[N][N];
bool vis[N];
int dis[N];
int Dijkstra()
{
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++)
	   dis[i]=g[1][i];
	vis[1]=1;
	for(int k=1;k<n;k++)
	{
		int maxn=0,u;
		for(int i=1;i<=n;i++)
		{
			if(!vis[i]&&maxn<dis[i])
			{
				maxn=dis[i];
				u=i;
			}
		}
		vis[u]=1;
		for(int i=1;i<=n;i++)
		{
			if(!vis[i])
			{
				int ans=min(maxn,g[u][i]);
				if(ans>dis[i])
				   dis[i]=ans;
			}
		}
	}
	return dis[n];
}
int main()
{
	int t;
	cin>>t;
	for(int i=1;i<=t;i++)
	{
		cin>>n>>m;
		memset(g,0,sizeof(g));
		for(int j=0;j<m;j++)
		{
			int a,b,w;
			cin>>a>>b>>w;
			g[a][b]=g[b][a]=w;
		}
		printf("Scenario #%d:\n",i);
		printf("%d\n\n",Dijkstra());
	}
	return 0;
}