1. 程式人生 > >1076 Forwards on Weibo[BFS][一般]

1076 Forwards on Weibo[BFS][一般]

地方 format stream sum sep output ase ostream weibo

1076 Forwards on Weibo (30)(30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID‘s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

題目大意:給出一個關註網絡,檢測在L內,一個用戶發帖,最多有多少個轉發量,像是寬度優先遍歷,是有向圖。

#include <iostream>
#include <algorithm>
#include <vector>
#include<queue>
using namespace std;
vector<int> user[1010];
int vis[1010];
int main() {
    int n,L;
    queue<int> qu;
    cin>>n>>L;
    int k,temp;
    for(int i=1;i<=n;i++){
        cin>>k;
        for(int j=0;j<k;j++){
            cin>>temp;
            user[temp].push_back(i);
        }
    }
    cin>>k;
    int ct=0,level=0,num;
    for(int i=0;i<k;i++){
        fill(vis,vis+n+1,0);//開心到哭泣,這裏錯了,導致過不去,因為編號是從1-n,所以就導致了最後一個點被賦值為1之後,一直為1.
        cin>>temp;
        ct=0,level=0;
        while(!qu.empty())qu.pop();
        qu.push(temp);
        vis[temp]=1;
        qu.push(-1);
        while(level!=L){
            while(!qu.empty()){
                num=qu.front();
                qu.pop();
                if(num==-1){
                    qu.push(-1);
                    break;
                }
                for(int j=0;j<user[num].size();j++){
                    if(!vis[user[num][j]]){
                        qu.push(user[num][j]);//將其放入
                        vis[user[num][j]]=1;
                        ct++;
                    }
                }
            }
            level++;
        }
        cout<<ct;
        if(i!=k-1)cout<<\n;
    }
    return 0;
}

我的AC代碼,一般出現段錯誤就是數組長度設置的太小了,反正這次是這樣。

1.還有一個困擾我的地方,“and that only L levels of indirect followers are counted.”,這裏其實是很簡單,並不是第一層的不算,所有的能轉發的人都算在內。

1076 Forwards on Weibo[BFS][一般]