1. 程式人生 > >PAT 1076 Forwards on Weibo

PAT 1076 Forwards on Weibo

back evel orm content one guarantee cati code queue

1076 Forwards on Weibo (30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤), the number of users; and L (≤), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID

‘s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define MAXN 10005
int n,L;
vector<vector<int>> vec;
int vis[MAXN] = {0};


void bfs(int x){
    vis[x] = 1;
    queue<int> que;
    que.push(x);
    int cnt = 0;
    while(cnt!=L&&!que.empty()){
        cnt++;
        int len = que.size();    //計算層數這麽寫!!
        for(int i=0;i < len;i++){
            int tx = que.front();que.pop();
            for(int j=0;j < vec[tx].size();j++){    //此處i,j又寫重復了
                if(!vis[vec[tx][j]]){
                    que.push(vec[tx][j]);
                    vis[vec[tx][j]] = 1;
                }
            }
        }
    }
}







int main(){
    cin >> n >> L;
    vec.resize(n+1);
    for(int i=1;i <= n;i++){
        int t;cin >> t;
        for(int j=0;j < t;j++){   //i,j兩處寫重復了!
            int num; cin >> num;
            vec[num].push_back(i);    //followed是關註的人,一開始寫反了
        }
    }

    int K; cin >> K;
    while(K--){
        fill(vis,vis+n+1,0);
        int Q; cin >> Q;
        bfs(Q);
        int count = 0;
        for(int i=1;i <= n;i++){
            if(vis[i]) count++;
//            cout << vis[i] << " ";
        }
        cout << count-1 << endl;
    }


    return 0;
}

一杯茶,一包煙,一條圖論寫一天

 

PAT 1076 Forwards on Weibo