1. 程式人生 > >1555: Inversion Sequence (通過逆序數復原序列 vector的騷操作!!!)

1555: Inversion Sequence (通過逆序數復原序列 vector的騷操作!!!)

include disabled 題目 submit 我們 直接 origin for each type

1555: Inversion Sequence

Time Limit: 2 Sec Memory Limit: 256 Mb Submitted: 519 Solved: 195


Description

For sequence i1, i2, i3, … , iN, we set aj to be the number of members in the sequence which are prior to j and greater to j at the same time. The sequence a1, a2, a3, … , aN is referred to as the inversion sequence of the original sequence (i1, i2, i3, … , iN). For example, sequence 1, 2, 0, 1, 0 is the inversion sequence of sequence 3, 1, 5, 2, 4. Your task is to find a full permutation of 1~N that is an original sequence of a given inversion sequence. If there is no permutation meets the conditions please output “No solution”.

Input

There are several test cases.
Each test case contains 1 positive integers N in the first line.(1 ≤ N ≤ 10000).
Followed in the next line is an inversion sequence a1, a2, a3, … , aN (0 ≤ aj < N)
The input will finish with the end of file.

Output

For each case, please output the permutation of 1~N in one line. If there is no permutation meets the conditions, please output “No solution”.

Sample Input

5
1 2 0 1 0
3
0 0 0
2
1 1

Sample Output

3 1 5 2 4
1 2 3
No solution

Hint

Source

題目意思:通過逆序數復原序列
題目意思和樣例很難懂
比如樣例1:
1 2 0 1 0
1 表示序列中1的前面比1大的數有1個
2 表示序列中2的前面比2大的數有2個
0 表示序列中3的前面比3大的數有0個
1 表示序列中4的前面比4大的數有1個
0 表示序列中5的前面比5大的數有0個 解析一下: 1的前面有1個比1大的,2的前面有2個比2大的,4的前面有一個比4大的 首先,1的位置可以直接確定,因為除了1以外所有的數都比1大,所以1肯定在第二個位置

得到 _ 1 _ _ _
然後考慮2,2的前面有兩個數字比2大,因為我們已經確定的數字只有1,1已經比2小了,所以要無視1,其實就是說,2的前面要留下2個空位,這樣那2個空位只能放3,4,5,就能保證2的前面一定會有2個數字比它大了,所以
得到 _ 1 _ 2 _
再考慮3,3的前面沒有比3大的,1和2都比3小應該直接無視,那麽3只能放在第一個位置
得到3 1 _ 2 _
再考慮4,4的前面有一個比它大,所以4的前面應該留一個空格
得到3 1 _ 2 4
最後
得到3 1 5 2 4 具體做法:
采用vector模擬該操作
很神奇!......
#include<cstdio>
#include<string>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<cstring>
#include<set>
#include<queue>
#include<algorithm>
#include<vector>
#include<map>
#include<cctype>
#include<stack>
#include<sstream>
#include<list>
#include<assert.h>
#include<bitset>
#include<numeric>
#define max_v 10005
using namespace std;
int a[max_v];
vector<int> v;
int main()
{
    int n;
    while(cin>>n)
    {
        v.clear();
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        int flag=1;
        for(int i=n;i>=1;i--)
        {
            if(v.size()<a[i])
            {
                flag=0;
                break;
            }
            v.insert(v.begin()+a[i],i);
        }
        if(flag)
        {
            vector<int>::iterator it;
            it=v.begin();
            printf("%d",*it);
            it++;
            for(;it!=v.end();it++)
                printf(" %d",*it);
            printf("\n");
        }else
        {
            printf("No solution\n");
        }
    }
    return 0;
}
/*
題目意思:通過逆序數復原序列
題目意思和樣例很難懂
比如樣例1:
1 2 0 1 0
1 表示序列中1的前面比1大的數有1個
2 表示序列中2的前面比2大的數有2個
0 表示序列中3的前面比3大的數有0個
1 表示序列中4的前面比4大的數有1個
0 表示序列中5的前面比5大的數有0個

解析一下:

1的前面有1個比1大的,2的前面有2個比2大的,4的前面有一個比4大的 

首先,1的位置可以直接確定,因為除了1以外所有的數都比1大,所以1肯定在第二個位置
得到 _ 1 _ _ _
然後考慮2,2的前面有兩個數字比2大,因為我們已經確定的數字只有1,1已經比2小了,所以要無視1,其實就是說,2的前面要留下2個空位,這樣那2個空位只能放3,4,5,就能保證2的前面一定會有2個數字比它大了,所以
得到 _ 1 _ 2 _
再考慮3,3的前面沒有比3大的,1和2都比3小應該直接無視,那麽3只能放在第一個位置
得到3 1 _ 2 _
再考慮4,4的前面有一個比它大,所以4的前面應該留一個空格
得到3 1 _ 2 4
最後
得到3 1 5 2 4

具體做法:
采用vector模擬該操作
很神奇!......

*/

1555: Inversion Sequence (通過逆序數復原序列 vector的騷操作!!!)