1. 程式人生 > >HDU-ACM課堂作業 Least Common Multiple

HDU-ACM課堂作業 Least Common Multiple

str accept otto mis family ast algo turn space

Least Common Multiple

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 178 Accepted Submission(s) : 38
Problem Description The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.<br><br>

Input Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.<br>

Output For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.<br>

Sample Input 2 3 5 7 15 6 4 10296 936 1287 792 1

Sample Output 105 10296

Source East Central North America 2003, Practice 這裏INT-32類型的變量直接用int就可以啦
#include<iostream>
#include<stdio.h>
#include<algorithm> 
#include<string.h>
#include <iomanip>
#include<math.h>
using namespace std;

int GCD(int num1, int num2)
{
    if (num1%num2 == 0)
        return num2;
    else return  GCD(num2, num1%num2);
}
int LCM(int a, int b)
{
    int temp_lcm;
    temp_lcm = a / GCD(a, b)*b; //先除後乘,否則數據溢出導致WA
    return temp_lcm;
}

int main() {
    //數據組數
    int n = 0;
    while (cin >> n) {
        while (n--) {
            //變量數
            int k = 0;
            cin >> k;
            //將變量初始化
            int b = 0;
            int lcm, a = 1;
            for (int i = 0; i < k; i++) {
                //將每次輸入的變量設置為b,計算a與b的LCM,隨後將LCM賦值給a
                cin >> b;
                lcm = LCM(a, b);
                a = lcm;
            }
            cout << lcm << endl;
        }
    }
}


HDU-ACM課堂作業 Least Common Multiple