1. 程式人生 > >Hdoj 1009.FatMouse' Trade 題解

Hdoj 1009.FatMouse' Trade 題解

earch script multiple name tell spec for python printf

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

Author

CHEN, Yue

Source

ZJCPC2004


思路

題目的大意是有\(J[i]\)個豆子,要得到的話交\(F[i]\)

個貓糧,給你m份貓糧,問你如何最大化受益

顯然是根據\(J[i]/F[i]\)的高低排序,也就是我們通俗意義上的性價比

代碼

#include<bits/stdc++.h>
using namespace std;
struct node
{
    double j;   //豆子
    double f;   //貓糧
    double single;      //豆子/貓糧
} a[1010];
int main()
{
    int m,n;
    while(cin>>m>>n)
    {
        if(m==-1 && n==-1) break;
        for(int i=1;i<=n;i++)
        {
            cin >> a[i].j >> a[i].f;
            a[i].single = a[i].j/a[i].f;
        }   //讀入
        sort(a+1,a+n+1,[=](node x,node y) -> bool {return x.single > y.single;});//lamba表達式作為cmp函數
        
        double ans = 0.0;
        for(int i=1;i<=n;i++)
        {
            if(m>a[i].f)
            {
                ans += a[i].j;
                m -= a[i].f;
            }else
            {
                ans += m/a[i].f*a[i].j;
                break;  //不夠只能按百分比買
            }
        }
        printf("%.3lf\n",ans);
    }
    return 0;   
}

Hdoj 1009.FatMouse' Trade 題解