1. 程式人生 > >HDU-1009——FatMouse' Trade

HDU-1009——FatMouse' Trade

                                        FatMouse' Trade

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

Sample Output

13.333

31.500

題意描述:

老鼠手裡總共有n個房間,m個貓糧,每個房間不同數量的老鼠喜歡的食物,想要獲得食物就要給貓貓糧。給出了每個房間的老鼠食物的食物量,及所對應需要的貓糧。可以給少於對應房間的貓糧,當然得到的食物也是對應比例的。求能獲得最大喜歡食物的量。

解題思路:

簡單的貪心,求出每個房間每個貓糧的價值,根據價值進行排序。從價值最大的開始換取,當不夠把一個房間的食物換完是,換取對比例的食物。

程式程式碼:

#include<stdio.h>
#include<algorithm>
using namespace std;
struct A
{
	int a;
	int b;
	double c;
}q[1010];
double cmp(struct A a,struct A b)
{
	return a.c>b.c;
}
int main()
{
	int n,m,i,j;
	double sum;
	while(scanf("%d%d",&m,&n))
	{
		if(m==-1&&n==-1)
			break;
		sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&q[i].b,&q[i].a);
			q[i].c=q[i].b*1.0/q[i].a;
		}
		sort(q+1,q+n+1,cmp);
		for(i=1;i<=n;i++)
		{
			if(q[i].a<=m)
			{
				m=m-q[i].a;
				sum+=q[i].b;
			}
			else
			{
				sum+=m*q[i].c;
				break;
			}
		}
		printf("%.3f\n",sum);
	}
	return 0;
}