1. 程式人生 > >HDU(1004)Let the Balloon Rise

HDU(1004)Let the Balloon Rise

esc 方式 pin oat num 賦值 strcmp inpu tell

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 149425 Accepted Submission(s): 59368

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges‘ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.


A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5 green red blue red red 3 pink orange pink 0

Sample Output

red pink

第一種實現方式:結構體比較:

#include<iostream>
#include<string.h>
using namespace std;
struct node
{
    char balloon[20];
    int count_ball=0;
};
int main()
{
    int N;
    struct node Color[1005],Temp;
    
    while (cin >> N)
    {
        if (N == 0)
            break;
        int i, j;
        for (i = 0; i < N; i++)
        {
            cin >> Color[i].balloon;
            Color[i].count_ball = 1;
        }
        for (i = 0; i < N; i++)//從當前的顏色開始計數,直到後面的顏色全部統計完,則為該顏色的數量
        {
            for (j = i + 1; j < N; j++)
            {
                if (strcmp(Color[i].balloon, Color[j].balloon) == 0)
                {
                    Color[i].count_ball++;
                }
            }
        }
        for (i = 0; i < N - 1; i++)//比較,求出最大的顏色
        {
            for (j = i; j < N - 1 - i; j++)
            {
                if (Color[j].count_ball > Color[j + 1].count_ball)
                {
                    Temp = Color[j];
                    Color[j] = Color[j + 1];
                    Color[j + 1] = Temp;
                }
            }
        }
        cout <<Color[i].balloon << endl;
    }
    
    return 0;
}

第二種實現方式Map:

#include<iostream>
#include<string>
#include<map>
using namespace std;

int main()
{
    int N;
    map<string, int> ballsum;
    string str;
    while (cin >> N&&N > 0)
    {
        ballsum.clear();//清空map
        while (N--)
        {
            cin >> str;
            ballsum[str]++;
        }
        int max = 0;
        string maxclor;
        map<string, int>::iterator iter;//定義叠代器
        for (iter = ballsum.begin(); iter != ballsum.end(); iter++)//叠代查找
        {
            if (iter->second > max)//尋找最大的顏色數量
            {
                max = (*iter).second;
                maxclor = (*iter).first;//將map中顏色值賦值給maxcolor
            }
        }
        cout << maxclor << endl;
    }


    return 0;
}

HDU(1004)Let the Balloon Rise