1. 程式人生 > >hdu 1004 (Let the balloon rise) c、c++

hdu 1004 (Let the balloon rise) c、c++

hdu 1004(Let the balloon rise)

題目http://acm.hdu.edu.cn/showproblem.php?pid=1004 Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input 5 green red blue red red 3 pink orange pink 0

Sample Output red pink 分析:要求輸入數字(0 < N <= 1000),和對應數字的顏色,返回輸入次數最多的顏色 思路:1. 把輸入傳入char ball[1001][16]中,並建立int num[1001],儲存每個輸入的顏色重複的個數,最後print num最大的ball 2. 利用c++中的map,在每個顏色後記錄輸入的次數

c語言


    //
    //  main.c
    //  hdu1004
    //
    //  Created by zhan_even on 2018/10/18.
    //  Copyright © 2018年 zhan_even. All rights reserved.
    //
    #include<stdio.h>
    #include<string.h>
    int main()
    {
        int i,j,pos,max,n;
        int num[1001];
        char  ball[1001][16];
        while (scanf("%d",&n)==1&&n)
        {
            scanf("%s",ball[0]);
            num[0]=1;
            for (i=1;i<n;i++)
            {
                scanf("%s",ball[i]);
                num[i]=1;
                for  (j=0;j<i;j++)
                {
                    if (strcmp(ball[i],ball[j])==0)
                    {
                        num[i]++;
                    }
                }
            }
            pos=0;
            max=0;
            for (i=0;i<n;i++)
            {
                if (num[i]>max)
                {
                    max=num[i];
                    pos=i;
                }
                
            }
            printf("%s\n",ball[pos]);
        }
        return 0;
    }

 


c++:

//
//  main.cpp
//  hdu1004mp
//
//  Created by zhan_even on 2018/10/19.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
#include <map>
#include <string>

using namespace std;

int main(void) {
    map<string, int> ball;
    int n;
    string color, max_color;

    while (cin >> n&&n) {
        ball.clear();
        while (n--) {
            cin >> color;
            ball[color]++;
        }
        map<string,int>::iterator iter;
        int max = 0;
        for(iter = ball.begin(); iter != ball.end(); iter++){
            if(iter -> second > max){
                max = iter -> second;
                max_color = iter -> first;
            }
        }
        cout << max_color <<endl;
        
    }
    
    return 0;
}

收穫:一開始使用c語言程式設計,思路簡單,但是在在寫出之後上網搜尋發現還可以用map的方法,順便了解了一下C++的程式設計規範,學習了一下基本的map的運用。