【POJ - 3253】Fence Repair(貪心,時光倒流)
題幹:
Description
Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N
FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.
Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N
Input
Line 1: One integer N, the number of planks
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input
3
8
5
8
Sample Output
34
Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
Source
題目大意:
給一塊長木板,現要將其鋸成n段,共需鋸n-1次,每次鋸的代價為所鋸木板的長度,求最小總代價。
解題報告:
若把木板切割過程畫成一個樹的話,根就是總長度,枝葉是n段切割後的木板長度,顯然費用就是所有的節點的和,所以也就是 葉節點的大小*節點深度,所以我們希望深度越大的木板越短越好。所以逆向生成一棵樹,從葉節點開始一次合併最小和次小木板直到生成一棵樹。或用交換排序貪心法去思考。
AC程式碼:
#include<cstdio>
#include<queue>
#include<vector>
using namespace std;
priority_queue<int,vector<int>,greater<int> >que;//小根堆
int n;
long long ans;
int main(){
scanf("%d",&n);
for(int i=1,x;i<=n;i++){
scanf("%d",&x);
que.push(x);
}
for(int i=1,x,y;i<n;i++){
x=que.top();que.pop();
y=que.top();que.pop();
ans+=x+y;
que.push(x+y);
}
printf("%lld\n",ans);
return 0;
}
注意一個錯誤程式碼:
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#define ll long long
using namespace std;
ll a[200000];
int main()
{
int n;
cin>>n;
ll sum = 0,ans = 0;
for(int i = 1; i<=n; i++) {
scanf("%lld",&a[i]);
sum += a[i];
}
sort(a+1,a+n+1);
if(n == 1){
printf("0\n");return 0;
}
ans = a[1] + a[2];
for(int i = 3; i<=n; i++) {
ans += ans + a[i];
}
printf("%lld\n",ans);
return 0 ;
}
錯誤原因:直接把剛求出來的ans接著帶入求了,這樣是不對的!因為這個ans不一定被接著用。。
總結:
有坑:注意這題說5e4 * 2e4的資料量貌似剛剛好1e9,貌似可以int,但是這題必須longlong才能過!原因自己想。(其實ans只要開longlong就可以了)