F - CONTINUE...? (給一個數n,1到n標記,把他分成兩部分且相等)
DreamGrid has classmates numbered from to . Some of them are boys and the others are girls. Each classmate has some gems, and more specifically, the -th classmate has gems.
DreamGrid would like to divide the classmates into four groups , , and such that:
-
Each classmate belongs to exactly one group.
-
Both and consist only of girls. Both and consist only of boys.
-
The total number of gems in and is equal to the total number of gems in and .
Your task is to help DreamGrid group his classmates so that the above conditions are satisfied. Note that you are allowed to leave some groups empty.
Input
There are multiple test cases. The first line of input is an integer indicating the number of test cases. For each test case:
The first line contains an integer () -- the number of classmates.
The second line contains a string () consisting of 0 and 1. Let be the -th character in the string . If , the -th classmate is a boy; If , the -th classmate is a girl.
It is guaranteed that the sum of all does not exceed .
Output
For each test case, output a string consists only of {1, 2, 3, 4}. The -th character in the string denotes the group which the -th classmate belongs to. If there are multiple valid answers, you can print any of them; If there is no valid answer, output "-1" (without quotes) instead.
Sample Input
5 1 1 2 10 3 101 4 0000 7 1101001
Sample Output
-1 -1 314 1221 3413214
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=1e6+10;
char s[N];
bool vis[N];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
ll n;
scanf("%lld",&n);
scanf("%s",s);
for(int i=0;i<=n;i++)
vis[i]=false;
ll sum=n*(n+1)/2;
if(sum%2)
{
printf("-1\n");
continue;
}
sum/=2;
for(ll i=n; i>=1; i--)
{
if(sum>0&&sum>=i)
{
vis[i]=true;
sum-=i;
}
if(sum<=0)break;
}
for(int i=1; i<=n; i++)
{
if(s[i-1]=='0')
{
if(vis[i])printf("2");
else printf("1");
}
else
{
if(vis[i])printf("4");
else printf("3");
}
}
printf("\n");
}
return 0;
}