1. 程式人生 > >ZOJ - 3469-Food Delivery (區間DP)

ZOJ - 3469-Food Delivery (區間DP)

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X

meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index

. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index

.

 

Input

 

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

 

Output

 

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

 

Sample Input

 

5 1 0
1 1
2 2
3 3
4 4
5 5
 

 

Sample Output

 

55

思路:因為送外賣只要經過某一點,如果哪一點的外賣沒有送達,哪先送這一點,這樣一定比不送優。

           dp[i][j][0]代表送完餐後在i點,dp[i][j][1]代表送完餐後在j點。

           tem表示還未送到餐的其他人,加上正在去送餐的人的怒氣和。

#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
struct node
{
    int x,b;
} A[1010];
int cmp(node a,node b)
{
    return a.x<b.x;
}
int sum[1010],dp[1010][1010][2];
int main()
{
    int n,v,x,pos;
    while(~scanf("%d%d%d",&n,&v,&x))
    {
        for(int i=1; i<=n; i++)
            scanf("%d%d",&A[i].x,&A[i].b);
        ++n;
        A[n].x=x,A[n].b=0;
        sort(A+1,A+1+n,cmp);
        memset(dp,0x3f,sizeof(dp));
        for(int i=1; i<=n; i++)
            sum[i]=sum[i-1]+A[i].b;
        pos=0;
        for(int i=1;i<=n;i++)
        {
            if(A[i].x==x)
            {
                pos=i;
                break;
            }
        }
        dp[pos][pos][1]=dp[pos][pos][0]=0;
        for(int i=pos; i>0; i--)
        {
            for(int j=pos; j<=n; j++)
            {
                int tem=sum[n]-sum[j]+sum[i-1];
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(A[i+1].x-A[i].x)*(tem+A[i].b));
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(A[j].x-A[i].x)*(tem+A[i].b));
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(A[j].x-A[i].x)*(tem+A[j].b));
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(A[j].x-A[j-1].x)*(tem+A[j].b));
            }
        }
        printf("%d\n",min(dp[1][n][0],dp[1][n][1])*v);
    }
}