1. 程式人生 > >Friend-Graph

Friend-Graph

Problem Description

It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.

 

 

Input

The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.(n≤3000)

Then there are n-1 rows. The ith row should contain n-i numbers, in which number aij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.

 

 

Output

Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.

 

 

Sample Input

 

1

4

1 1 0

0 0

1

 

 

Sample Output

 

Great Team!

 

 

Source

2017中國大學生程式設計競賽 - 網路選拔賽

 

題目大意:給定n個人,如果有連續3個人及以上是朋友,或者有3個人及以上不認識,那麼Bad Team!,否則Great Team!

#include<iostream>
#include<cstdio>
using namespace std;
int G[3003][3003];
int main()
{
    int T;
	scanf("%d",&T);
	while(T--)
	{	
	    int n;
		scanf("%d",&n);
		for(int i=1;i<=n-1;i++)
			for(int j=i+1;j<=n;j++)			
				scanf("%d",&G[i][j]);
		int flag=0;		
		for(int i=1;i<=n-1;i++)
		{
			int sum1=0,sum2=0;
			for(int j=i+1;j<=n;j++)
			{
				if(G[i][j]==1)
				   sum1++;
				if(G[i][j]==0)
				   sum2++;	
				if(sum1>=3||sum2>=3)
					flag=1;	
			}
	
		}	
		if(flag)
		  printf("Bad Team!\n");		
		else
		  printf("Great Team!\n");		
	}
	
	return 0;
	
}